check setup.yml show multiple configre selinux and timezome how to remove dublicate config

Tags: #<Tag:0x00007f0f19305e88>

postgres_repo_rpm_name: pgdg-centos92-9.2-7.noarch.rpm

To see the list of valid variables in Bahmni please refer to:

https://bahmni.atlassian.net/wiki/display/BAH/List+Of+Configurable+Installation+Variables

timezone: Asia/Kolkata implementation_name: default selinux_state: enforcing postgres_repo_rpm_name: pgdg-centos92-9.2-7.noarch.rpm# To see the list of valid variables in Bahmni please refer to: https://bahmni.atlassian.net/wiki/display/BAH/List+Of+Configurable+Installation+Variables

timezone: Asia/Kolkata implementation_name: default selinux_state: disabled postgres_repo_rpm_name: pgdg-centos92-9.2-7.noarch.rpm

To see the list of valid variables in Bahmni please refer to:

https://bahmni.atlassian.net/wiki/display/BAH/List+Of+Configurable+Installation+Variables

timezone: Asia/Kolkata implementation_name: default selinux_state: disabled postgres_repo_rpm_name: pgdg-centos92-9.2-7.noarch.rpm# To see the list of valid variables in Bahmni please refer to: https://bahmni.atlassian.net/wiki/display/BAH/List+Of+Configurable+Installation+Variables

timezone: Asia/Kolkata implementation_name: default selinux_state: disabled postgres_repo_rpm_name: pgdg-centos92-9.2-7.noarch.rpm

To see the list of valid variables in Bahmni please refer to:

https://bahmni.atlassian.net/wiki/display/BAH/List+Of+Configurable+Installation+Variables

timezone: Asia/Kolkata implementation_name: default selinux_state: disabled postgres_repo_rpm_name: pgdg-centos92-9.2-7.noarch.rpm

To see the list of valid variables in Bahmni please refer to:

https://bahmni.atlassian.net/wiki/display/BAH/List+Of+Configurable+Installation+Variables

timezone: Asia/Kolkata implementation_name: default selinux_state: disabled

You got the duplication because you run the command: curl -L https://goo.gl/R8ekg5 >> /etc/bahmni-installer/setup.yml (…from the installation steps) multiple times

If the setup.yml filel already exists in /etc/bahmni-installer/ , the >> operator in the command will append data from the command to the end of the file. (…see this)

So, I think you can just remove everything in setup.yml and copy-paste the content at https://goo.gl/R8ekg5. You’ll then change timezone: Asia/Kolkata accordingly

I removed duplicate setup.yml then after i installing bahmni i getting Error https://hastebin.com/utacemulos.pl

and i open browser

Run yum list installed | grep bahmni and show us which components you have installed and then sudo service --status-all so we can see which ones are actually running

i have done this also

https://hastebin.com/egiwutubag.cs

please this why giving me problem

You didn’t include the output of sudo service --status-all

…run the command and share the output

i used this command service --status-all

https://hastebin.com/etemitifob.tex

then after i am getting down maintance in bahmni

I see the following error in the log:

server version: 9.2.24; pg_dump version: 8.4.20\npg_dump: aborting because of server version mismatch

…looks like the installation did not complete! Can you check if you have multiple versions of postgresql installed?

run:

find / -name pg_dump -type f 2>/dev/null

when i type the command

find / -name pg_dump -type f 2>dev/null

two dump files

/usr/pgsql-9.2/bin/pg_dump

/usr/bin/pg_dump

That’s why you are getting the “server version mismatch” error.

Try creating a symlink to psql-9.2 and do bahmni install again.

sudo ln -s /usr/pgsql-9.2/bin/pg_dump /usr/bin/pg_dump --force

1 Like

unable to open bahmni getting Error in The request information does not exits

Was the previous error resolved? You should maybe mark this thread as solved if you got the initial error resolved.

It’s a different error you are getting now and we can respond better on this thread since your are posting the same question there.

i run command

sudo ln -s /usr/pgsql-9.2/bin/pg_dump /usr/bin/pg_dump --force

server mismatch Error is reslove openerp is working but bahmni doashboard not working it is showing the Required information does not exits

Bahmni Apps dashboard has nothing to do with Postgres. You need to figure out why the “home page” in your screen didn’t load up.

  • what comes up in the javascript console?
  • it maybe that bahmniapps didn’t get installed properly