Changing dl.bintray url (that installs ansible) for bahmni command.

Hi @binduak @swathivarkala

On my Ethiopian server while upgrading bahmni, “bahmni -i inventory install” first tries to install ansible 2.3 i.e Output of sudo bahmni -i inventory install is Installing Ansible from

Since dl.bintray is blocked in Ethiopia, “sudo bahmni -i inventory install” fails. I tried to change the dl.bintray url in /opt/bahmni-installer/bahmni-command-line-tool/ but when I ran the installer it picks it up.

My bahmni_repo_url points to and I’ve installed ansible 2.3 manually.

How can I disable the above d.bintray url so that its not picked up.

Wow, why Bintray is blocked in Ethiopia? Are you sure about that?

Hi @jmbabazi,

The above file path is the not the correct one. You need to do the respective changes in /usr/lib/python2.6/site-packages/bahmni-0.1-py2.6.egg/ file.

@jbaruch, I’m sure. Usually when I upgtrade my servers there. I have to use alternate urls.

Thanks @binduak, will try this out. seems to be down. I can’t access it from the US!