challange while setting up OpenMRS SDK


(CLIFF GITA) #1

Application Name: Bahmni specify) **Version Number:**2

Question: hello, am experiencing a challenge on setting up the OpenMRS SDK, when i run " mvn org.openmrs.maven.plugins:openmrs-sdk-maven-plugin:setup-sdk" and “mvn openmrs-sdk:help” in the command line i get several warning messages saying “failed to retrieve plungin descriptor for org.apache.maven.plugins” yet i have installed maven,jdk,git and are all fully running. Any one who can help me out on this.


(Juliet Wamalwa) #2

Sorry kindly share the error output here


(Stephen Senkomago Musoke) #3

In addition to the error output also share the operating system, maven, JDK and git versions that you are running


(CLIFF GITA) #4

Capture
Thats the erro am getting


(Juliet Wamalwa) #5

Its not clear copy the entire error and paste in paste bin and share the link here.


(CLIFF GITA) #6

OS is 64 bit windows 7 operating system,apache maven 3.6, jdk1.8.0_131Capture


(CLIFF GITA) #7

kinda stuck on how to copy it from the command line, may be you can help elaborate more


(Juliet Wamalwa) #8

Its my pleasure. click on this link https://pastebin.com/.

  • copy the error output and paste in pastebin where the cursor is blinking from. - Click on create new paste - Enter the code given if any - click submit. - Copy the link after submit and share here.

Hope it works for you.


(CLIFF GITA) #9

Here is the link https://pastebin.com/UW5EwfK0


(Juliet Wamalwa) #10

perfect. you haven’t submitted what @ssmusoke pointed out


(CLIFF GITA) #12

OS is 64 bit windows 7 operating system,apache maven 3.6, jdk1.8.0_131


(Nathan Ruhanga) #13

@gcliff , kindly also try to ensure reliable Internet for safe downloads of the required files.


(Stephen Senkomago Musoke) #14

You seem to have connection timeout errors - check your Internet connection


(Juliet Wamalwa) #15

Thanks my mentor but its @gcliff not me. Once again thanks you


(CLIFF GITA) #16

hello Musoke, i worked on my connection but am still experiencing the same challenge with openmrs sdk


(Stephen Senkomago Musoke) #17

Please share the logs as text via PasteBin - as there is no way to know what is happening


(CLIFF GITA) #18

Here is the link from pastebin


(Stephen Senkomago Musoke) #19

Your SDK installation failed so there is no way you can use it from here


(CLIFF GITA) #20

oh okay and do u have any ideas on how i can fix this ??


(Stephen Senkomago Musoke) #21

It is a connection issue - try a different Internet connection which is more stable