Can't access our server with new iOS app

We are using a server based implementation of OpenMRS. I cannot seem to connect the new iOS app to our instance. I can connect to the Demo Server ( just fine.

REST is installed. But perhaps there is some additional configuration to allow the iOS client to access?

Does anyone have any advice? I really like the look of the iOS client and would like to use it in our hospital on iOS devices.

1 Like

@parkererway or @harshadura do you have any ideas?

1 Like

@jgabrysch Hi Jeremy,

Glad to find your interest on the iOS client. Please let us know your suggestions, ideas or improvements you would like to have on this iOS app.

To answer your question, Could you please mention which OpenMRS version you were using ? And also check whether this REST settings is allowed:

Also please mention what was the URL you tried in the host field ?

1 Like

Our REST services settings looks the same:

We are using 1.9. I have tried these URLs:

1 Like

Since you’re using 192.168.*.* URLs, I assume your installation is on the local network, the same network that your device is on? If you’re using devices with cellular capabilities, are they on the local network?

Yes, the device is connected to the local network. As a comparison, I can access other sites on our local network with no problem (our PACS server, etc).

Well, I see you are using LAN here. So the problem could be one of the many reasons.

  1. Access list issues.
  2. Port blocking.
  3. Proxy settings in your iPhone device. …are the ones came to my mind yet.

First try to do this, so we can simply determine whether the iPhone can connect to the server.

Open your iPhone’s Safari browser Type: Enter; do you see the OpenMRS web app ?

Let us know the outputs, Thanks!

Yes I can access the server through the browser.

Also, I misspoke about version. We are 2.1, not 1.9.

Additional thoughts on this? I can connect to the server using Safari on the iOS device. Therefore, what should I do to troubleshoot the other issues you mentioned: port blocking, access list issues, etc?

Thanks for any assistance!