Cannot view or manage Add Ons on Standalone 2.4 version on linux

Hi, I’m very new and have a very basic knowledge of linux use (i use ubuntu and lubuntu, i can manage doing some stuff using the terminal), and i’m getting this issue that as far as i know a lot of other people is having; after

"You cannot view or manage the Add Ons since you dont have the privileges and you are not an admin.

To get the permissions contact the system administrator."

So i’m stuck a this part and i’m not able to change the password, or create a personal user.

I’ve checked the other posts, most of them are on windows, and i have not been able to solve the issue with that info. I have already tried several installations on both pc i have (in Ubuntu 20.4 and Lubuntu), i’ve checked the java version, checked tomcat, tried installing with both non expert options that the 2.4 version gives me. Can someone help me with this? Thanks!

Hello @trinifarias could you provide any other information like logs and the user you are using to login? The more information you can share the easier it will be for someone to help.

I’m using user: admin and password: test . Now, by log, do you mean the one on the open mrs application controller, or the one on my ubuntu terminal, or both? thanks!

The OPENMRS app controller log

and the ubuntu terminal log

as far as i can see in lubuntu i have the same issue.

Just download and run this: Download OpenMRS from

Hi, I’ve alread triend downloading the 2.11 version several times in both computers. when i do that i get this error

org.springframework.beans.factory.BeanCreationException: category:41

I’ve checked those treads, and then tried to download and install tomcat, updated java but it continued happening after

Can you share the tomcat log, via, when you download and run the one in the link that i shared above?

ok, now it doesn’t even finish running XD it get only to this point

your logs are related with the database, is your database running and are you using the correct password to access it?

Access denied for user 'openmrs'@'localhost'

In the setup wizard, use your mysql root account and its equivalent password.

Hi again, regarding this two question, first is by wizar do you mean here (screenshot) ? because i have no other wizard launched as i have to ru the java-jar file from the terminal. The other question will be when do i get the mysql account?, that info was not on the readme :frowning: so i thought i did not need any account from beforehand. thanks for your patience, rookie here. Captura de pantalla de 2021-04-09 20-01-02|690x388

no, I have not created a data base yet, I’m new to open mrs, i’ve just tried the demo a bit to explore and i was trying to download the standalone version to explore and try to create a few registers

If you are using the standalone version, just delete the unzipped standalone folder, then unzip the downloaded standalone again and run.

:frowning: hi again, i’ve done it again and is still stop at the same part than last time, at this step

at … 22 more

i’ve already downloaded both versions several times and try to re-run the processs with no luck :(.

Can you share the contents of the tomcat log (in the logs folder under the standalone’s tomcat folder) via