Cannot start Data Integrity module 4.4.1

dataintegrity
Tags: #<Tag:0x00007fb864e09fb0>

(Fawwaz Yusran) #1

Module: Data Integrity

Module Version: 4.4.1

System Version: 2.0.6 (from OpenMRS SDK) and Refapp 2.6.1

Issue or Question: So I added the dataintegrity-4.4.1.omod (from Addons) to my modules folder, which already include all Refapp 2.6.1 modules. I started the server, then I logged in. I go to Data quality, and it gives me UI Framework error. Here’s the full error:

https://pastebin.com/tGfHzXCK

Can anyone help me? Thanks.


(Stephen Senkomago Musoke) #2

@f4ww4z you may have to check your logs to find the cause of error as I have been able to run the data integrity module with a brand new Reference Application 2.6.1 server created from SDK


(Fawwaz Yusran) #3

Hi @ssmusoke what version is your data integrity module?


(Fawwaz Yusran) #4

So I created the Platform 2.0.6 from SDK, then downloaded Refapp modules 2.6.1 from here and put them in my modules folder. it should be the same like yours, right?

This is my error in my openmrs.log : https://pastebin.com/nYXu7MJJ


(Stephen Senkomago Musoke) #5

Sorry for the delay in responding, I suggest that you create a Distribution Server with Reference Application 2.6.1 - that way you will have the right versions of the different modules.

Then you copy and paste the Data Integrity omod into the modules directory and run your server


(Fawwaz Yusran) #6

Thanks for helping @ssmusoke, I have created a distribution server (with my limited connection) for Refapp 2.6.1 and put data integrity 4.4.1 in modules folder and then started the server. But I still have the same UI Framework error as above. I’ll try Refapp 2.7.0 as it’s released now.


(Stephen Senkomago Musoke) #7

@f4ww4z I suggest that you try it with a new server that has a brand new database just to be sure. That is what I did and it worked


(Fawwaz Yusran) #8

@ssmusoke May I ask what is your uiframework and webservices.rest modules version?


(Stephen Senkomago Musoke) #9

Webservices 2.19.0 and uiframework 3.11.0 - the default from Ref App 2.6.1


(Fawwaz Yusran) #10

I also tried adding demo patient data (50), restarted, but it still gives me a uiframework error.