Cannot install openmrs on mac monterey (Intel chip)

I tried download from sourceforge then running jar file from terminal, when I tried clicking on install with sample data or install with no data getting error as follow.

MysqldResource] launching mysqld (driver_launched_mysqld_1)
Exception in thread "driver_launched_mysqld_1" Cannot run program "/Users/macbookpro/Downloads/referenceapplication-standalone-2.12.2/database/bin/mysqld": error=86, Bad CPU type in executable
	at java.base/
Caused by: Cannot run program "/Users/macbookpro/Downloads/referenceapplication-standalone-2.12.2/database/bin/mysqld": error=86, Bad CPU type in executable
	at java.base/java.lang.ProcessBuilder.start(
	at java.base/java.lang.ProcessBuilder.start(
	at java.base/java.lang.Runtime.exec(
	... 3 more
Caused by: error=86, Bad CPU type in executable
	at java.base/java.lang.ProcessImpl.forkAndExec(Native Method)
	at java.base/java.lang.ProcessImpl.<init>(
	at java.base/java.lang.ProcessImpl.start(
	at java.base/java.lang.ProcessBuilder.start(
	... 7 more

I tried killing process on port 3305 of MySQL, restarted MySQL also stopping MySQL of my system but nothing seems to be working.

can someone help me out here. Thanks for your valuable time :slight_smile:

any help/ guidance would be appreciated :wink:

1 Like

@jnsereko @jwnasambu do you have any idea concerning the issue above?

Hey there @kdaud thanks for giving your valuable time, I have already sorted it out some how by reinstalling MySQL and reinstall the openmrs software.

well thanks for all your time. :slight_smile:

1 Like