Cannot compile uicommons module SCSS content

Tags: #<Tag:0x00007f7908f47698>

Compiling the uicommons module returns the following error

Execution default of goal de.saumya.mojo:gem-maven-plugin:1.0.0-rc4:exec failed: Java returned: 1

My .rubygems folder inside the scss folder only has an empty bin folder. I am not sure if it has something to do with the error.

Any help is highly appreciated.

Sanjeet

Can you share the log via pastebin.com when you compile with? mvn clean install -e

https://pastebin.com/ZvcKKDxd

Thank you

Try to remove spaces from your path and then compile again. That is, remove the space from the folder: Java Projects

1 Like

Still has the same issue, could it be a space in my name? For instance *C:\Users\Sanjeet Chand.m2\repository\org*

Yes remove all spaces from everywhere.

Hello @dkayiwa facing the same error and also tried your path spaces suggestion, but not working. here my discussion for the same problem. Build error in openmrs-uicommons - #8 by herbert24

the build is successful on my side, can i see a screen shot of your path here

Hello, please check the screen shot of my path