Building OpenMRS, initialsetup failed

I’ve been working on openmrs-core on Ticket 4096. I forked and checked out the latest code from github and ran mvn clean install. Then proceeded to run jetty:run from the webapp directory. From the browser, I opened localhost:8080/openmrs and I was greeted with the intialsetup wizard. However I couldn’t complete the setup, encountered the following error message while it was updating the database:

openmrs_jetty_run_failed.txt (13.7 KB)

Steps to reproduce:


.../> cd openmrs-core

.../openmrs-core> mvn clean install

.../openmrs-core> cd webapp

.../openmrs-core> mvn jetty:run

Appreciate the help in diagnosing this issue.

This is a known problem which has not yet been fixed. The work around is to use MySQL 5.6


Hi Daniel

I installed mysql 5.6 and still getting the same error message.

% mysql --version
mysql  Ver 14.14 Distrib 5.6.32, for osx10.11 (x86_64) using  EditLine wrapper

What could be the problem now?

EDIT: It seems related to the downgrade from 5.7 to 5.6. Investigating a fix.

You openmrs installation is not using the mysql you have just installed. It is still using the other one. Try remove the other one.

Purging the existing mysql data in /usr/local/mysql and reinstalling from scratch worked. Thanks.