Build errors in openmrs core

I get the following errors with openmrs-core

I also get these after running mvn clean install

Kindly advise @dkayiwa, @jwnasambu, @herbert24, @sharif, @gcliff

Hello @gracebish,

Could you please mention the Java, Maven and MySQL versions installed in your computer.

Java 8 or (1.8) MySQL 5.6 or 5.7 is generally advised to run OpenMRS modules without any errors.

is your core module up to date with latest changes on master branch !. if not update it with git pull --rebase upstream master and re-run again.feel free to share the full error in cmd prompt

1 Like

@gracebish the is a unit test which is breaking the CI and to be able to get clear information about the error, kindly rerun mvn with -e switch.

1 Like

Thanks. My Java is 1.8, MySql 5.6, Maven 3.6 and i did a git pull --rebase upstream master right running the mvn

@gracebish are you getting these errors minus making any changes in the code ?

You have added three replies into 1 statement so its not clear. :upside_down_face:

I have not made changes in the code.

@gracebish are you still getting the same error after updating the branch with the latest changes?

Yes, i do get the same error

Am sorry to ask! how did you run into this error?

@jwnasambu, I got this after installing eclipse oxygen

Kindly confirm if it supports java 8

It supports Java 8.

your changes are probably breaking the code, may be you could share your PR

I have not made a PR yet, because these errors appeared when i imported the project into the workspace, then tried to pull the latest changes and run mvn clean install to see if these errors would disappear but in vain.

@grace Well, it could be an issue of eclipse oxygen version not supporting JUnit 5 test to be on the safe side ensure you are running eclipse oxygen 2018-12 and above.

@gracebish u can try the following steps

  1. git reset --hard upstream/master

  2. git clean -df

3.git fetch --all

  1. git pull --rebase upstream master

  2. mvn clean install

1 Like