Bahmni- OpenMRS is not working

The openmrs application is getting exit everytime I start the openmrsdb, I am not able to figure out the issues. Here are the details:

Log of openmrs:

Log of openmrsdb

Here is the docker container running:

@mohant please help

  1. Are you running docker on Windows platform? Which exact OS?
  2. Did you make any changes to .env or file / or to docker-compose.yml file before running?
  3. Can you mention the steps you took after cloning the git repo?
  4. I am assuming openmrs/bahmni never ran successfully on your machine, or were they running fine, and now stopped working?

Hi @gsluthra There was some port issues,It’s working fine now. Could you tell me how we can do the setup for radiology module in bahmni? Any documentation is there for that?

Hi @sunny123 you can refer to this Wiki page You need to bring up profile pacs and later use the commands mentioned in the above Wiki page to insert into modality and order_type tables.Also make sure the you have set the ip in openmrs–>Adminstration–>settings–>pacsquery. Hope this helps.

Hi @deepthi , I went through the documentation for the set up of pacs but I am getting down for maintenance page for dcm4chee-web3 . The server is down from bahmni right or Am I missing something? I am getting this from more 4-5 Days.

Please see the logs of bahmni services, to understand which service is down. You may need to restart the appropriate services.

Can you please check if your pacs-integration and pacsdb services are up and running.

Try restarting services
-docker compose restart proxy
-docker compose restart pacs-integration
-docker compose restart pacs-simulator
-docker compose restart dcm4chee

Hi @deepthi @gsluthra , @akhilantotharayil , I am getting issues on running the pacsdb, pacs-integration and dcm4chee.Only one can start at a time while running in container if I start the pacsdb , dcm4chee container get stop.

Here are logs of pacs-integration

Logs of pacsdb

Logs of dcm4chee

Let me know if i am missing anything for the setup of pascdb config for role of user

Could you please confirm if you’re using the bahmni-docker repository for your setup, or if you’ve copied over the services manually?

Regarding the database setup, could you provide some details or steps that were followed to set up the database?

I am using bahmni-docker repository for the setup and pulled the images and running it in container in docker desktop(windows)

  1. changed the COMPOSE_PROFILES = emr,openelis,odoo,pacs
  2. pulled the images
  3. running it in container in detach mode Followed the document Pacsdb is working fine but pacs-integration is giving me the error as


whats your system hardware requirement?

Also please check if your shell script is running properly without any errors, becuse logs shows pacs_integration_user doesnot exist which would be probably be due to permission issue while running shell script you can run that before you bring up containers/profile pacs.Try running the script in terminal and check if you have any issues may be try running with chmod +x and see then bring up containers.

Hi Deepthi, I run the shell script and it is working fine but again I am getting the same error pacs_integration_user doesnot exist.Please let me know if I am missing anything

Error in pacsdb:

Do I have to create the role also? As per my understanding it is already defined in env variables.

Hi @akhilantotharayil I am using windows and docker desktop .Could you tell me what exactly u want to know?

I want to know how much is the ram…processor in your system?

Yeah ok, 32GB RAM, 512 GB SSD.

Is it possible to recycle ? if yes then do these
docker volume prune
docker system prune
docker system prune -a
docker stop $(docker ps -a -q)
docker rm $(docker ps -a -q)
docker image prune -a
then in .env file add COMPOSE_PROFILES = bahmni-standard
then do docker compose up -d

Hi @deepthi, I have configured the pacs and openmrs in same system but now I want to install pacs in different system and communicate with the openmrs. As u mentioned here that we need to configure ip of dcm4chee (pacs) in openmrs settings.I am trying to save it but it’s not getting saved.

After saving it, it’s not reflecting in the settings page.

Hi @sunny123 instead of configuring in above path please navigate to Administration -->Maintenance -->settings–>search for pacs and try to do here and save

1 Like