bahmni-lab not start after install bahmni!!!


(Himabindu Akkinepalli) #7

Hi @zacrify,

You have jre1.8.0_131 installed in your machine. Change JAVA_HOME to /usr/java/jre1.8.0_131 and it lets you start bahmni-lab service.


(pi shetshotisak) #8

Hi I tried to change as you recommend but I still cannot start bahmni-lab service

# required by embedded tomcat as env variables
export SERVER_PORT=8052
export BASE_DIR=/var/run/bahmni-lab
export CONTEXT_PATH=/openelis
export WAR_DIRECTORY=/var/run/bahmni-lab/bahmni-lab
export SERVER_OPTS="-Xms512m -Xmx1024m -XX:PermSize=256m -XX:MaxPermSize=512m"
export DEBUG_OPTS="-agentlib:jdwp=transport=dt_socket,address=8001,server=y,suspend=n"
export JAVA_HOME=/usr/java/jre1.8.0_131


OPENELIS_DB_SERVER="localhost"

(pi shetshotisak) #9

you mean install jre 1.8.0_101 again right? (sorry i’m not a technical guy)


(Himabindu Akkinepalli) #10

Hi @zacrify, Can you share the output of the below command. Also share bahmni-lab.log file. java -version


(pi shetshotisak) #11
[zacrify1986@centos-1 /]$ sudo service bahmni-lab start
Starting bahmni-lab
[zacrify1986@centos-1 /]$ sudo service bahmni-lab status
Service bahmni-lab is not running

this is log file

nohup: failed to run command `/usr/java/jre1.8.0_101/bin/java': No such file or directory
nohup: failed to run command `/usr/java/jre1.8.0_101/bin/java': No such file or directory
nohup: failed to run command `/usr/java/jre1.8.0_101/bin/java': No such file or directory

java version

[zacrify1986@centos-1 /]$ java -version
java version "1.8.0_131"
Java(TM) SE Runtime Environment (build 1.8.0_131-b11)
Java HotSpot(TM) 64-Bit Server VM (build 25.131-b11, mixed mode)

(Himabindu Akkinepalli) #12

Hi @zacrify,

Not sure why it is looking for jre1.8.0_101 after changing JAVA_HOME to jre1.8.0_131. Can you share /etc/bahmni-installer/local file.


(pi shetshotisak) #13
localhost ansible_connection=local

[nagios-server]

[bahmni-emr]
localhost

[bahmni-emr-db]
localhost
[bahmni-emr-db-slave]

[bahmni-erp]
localhost
[bahmni-erp-db]
localhost
[bahmni-erp-db-slave]

[bahmni-lab]

[bahmni-lab-db]

[bahmni-lab-db-slave]

[bahmni-reports]
localhost

[bahmni-reports-db]

[bahmni-reports-db-slave]

[atomfeed-console]

[pacs-integration]

[pacs-integration-db]

[pacs-integration-db-slave]

[dcm4chee]
localhost

[dcm4chee-db]
localhost

[dcm4chee-db-slave]

[bahmni-event-log-service]

[bahmni-offline]

[mysql-backup-tool]

[postgres-backup-tool]

[bahmni-backup-artifacts]

[local:children]
nagios-server
bahmni-emr
bahmni-emr-db
bahmni-emr-db-slave
bahmni-lab
bahmni-lab-db
bahmni-lab-db-slave
bahmni-erp
bahmni-erp-db
bahmni-erp-db-slave
bahmni-reports
bahmni-reports-db
bahmni-reports-db-slave
pacs-integration
pacs-integration-db
pacs-integration-db-slave
dcm4chee
dcm4chee-db
dcm4chee-db-slave
bahmni-event-log-service
bahmni-offline
atomfeed-console
mysql-backup-tool
postgres-backup-tool
bahmni-backup-artifacts

(Himabindu Akkinepalli) #14

Hi @zacrify,[quote=“zacrify, post:13, topic:11832”] [bahmni-lab]

[bahmni-lab-db] [/quote]

Can you add localhost under both the modules as mentioned in this file and run bahmni -i local install command.


(andrew bhandari) #15

hi @zacrify

  1. login to your server
  2. cd /opt
  3. wget https://mirror.its.sfu.ca/mirror/CentOS-Third-Party/NSG/common/x86_64/jre-8u101-linux-x64.rpm
  4. yum install jre-8u101-linux-x64.rpm

let’s do this first, after finishing installation

service bahmni-lab start

and check whether it start or not service bahmni-lab status

try rebooting your server once, and try to start again bahmni-lab

hope it will work .


Bahmni installation failure in centos
Bahmni homepage error
(pi shetshotisak) #16

hi @binduak after I add localhost under bahmni-lab and bahmni-lab-db and local install it appear like this

[zacrify1986@centos-1 ~]$ bahmni -i local install
Installing Ansible from https://dl.bintray.com/bahmni/rpm/ansible-2.2.0.0-3.el6.             noarch.rpm...
Loaded plugins: fastestmirror, security
Setting up Install Process
Cannot open: https://dl.bintray.com/bahmni/rpm/ansible-2.2.0.0-3.el6.noarch.rpm.              Skipping.
Error: Nothing to do

(Himabindu Akkinepalli) #17

Hi @zacrify,[quote=“zacrify, post:16, topic:11832”] Cannot open: https://dl.bintray.com/bahmni/rpm/ansible-2.2.0.0-3.el6.noarch.rpm. [/quote] Are you able to access the above URL from browser.


Bahmni installation failure in centos
(pi shetshotisak) #18

hi @binduak yes i can

i tried to install again and completed install with the same problem persist

bahmni-lab is not running


(pi shetshotisak) #19

Hi @binduak I followed your step again and it’s work Thanks


(andrew bhandari) #20

hi @zacrify

are yo uable to make LAB order and test result can appear in patient dashboard on bahmni? i have an issue i can make lab order and i can test LAB after validating result i cant see anything in patient dashboard of lab result ? are you okay with this one ?


(pi shetshotisak) #21

I did not tried that yet. I just checked whether bahmni-lab was started or not. thanks for mention it. I will try that


(Jean Toussaint) #22

I have the same issue , bahmni lab (open Elis ) is running but does not appear in the home page , can you please give me a step by step way to make it resolve this issue . Thanks


(andrew bhandari) #23

look how i solve this issue LAB unable to sync


(Jarvis Jarvis) #24

[SOLVED]

after following @binduak on this post, after running bahmni -i local install,

Dasboard is “Down for Maintenance”

Then I deleted the file maintenance.enable at /var/www/hmtl folder

You can now see all three apps on the dashboard!

Thanks!


(Jarvis Jarvis) #25

which of @binduak’s steps did you follow?


(Angshuman Sarkar) #27

Is the lab working? Can you logon to ELIS? Also check the status

service bahmni-lab status