Bahmni is not loading

hy… My bahmni is not loading.It is still loading but home page is not coming… Openmrs is showing an error “openmrs is not able to start”… Can anyone know what is this error means and how can i solve it?? Pls find the attached photos of error logs and UI photos…

Regards Mithun

@mithu . Can you please check the status of all services try restart all services and check again

@harsha4444 i allready tried but,after that also facing same issue… .

You need to upload the entire openmrs.log to pastebin or in gist for us to get a better picture.

From the look of the limited log screenshot, it seems that it can not connect to the database. Have you changed the default password in “setup.yml” during installation?

  1. Check if mysql is up and running and check if with the specified username/password for openmrs, whether you can login to mysql.
  • check if mysql is up and running

service mysqld status

  • check the “/opt/openmrs/etc/openmrs-runtime.properties” file to see what user/password is being used.

cat /opt/openmrs/etc/openmrs-runtime.properties

  • try to login to openmrs database with the above username/password.

mysql -U[user] -p[password] openmrs

  1. If the above does not work, then try to post the entire openmrs.log (through pastebin)
  • First delete the older logs and then start the server. the logs are rolling, so it can be that the logs are spanning across multiple files.

service openmrs stop

rm -f /var/log/openmrs/.

service openmrs start

@angshuonline I had checked mysql status and its running… “cat /opt/openmrs/etc/openmrs-runtime.properties” using these comments i got the username and password and i can able to login…But show table comment is showing “command not found”… I can able to stop openmrs using openmrs stop comment but " rm -f /var/log/openmrs/ ."is saying cant remove,its a directory… Also im attaching entire logs…From yesterday morning only this issue is started…For last one year bahmni is using in our office and before that we didnt face an issue like this… Pls find the attached screen shots and txt file… mysql_running

Logs_bahmni.txt (7.3 KB)

thats ok. Seems OpenMRS db is not installed properly. can you check if there are other databases in there.

mysql -Uroot -p (will promot for password)

show databases

use openmrs (if the above command shows openmrs listed)

show tables

Show databases giving a message “ignoring query to other database”

From yesterday only this pblm is started… Before that everything was working properly… Is there is any pblm for entire db??

You mean to say that Bahmni was working on that machine before? Assuming so,

  • Have you done (like install, update, backup or ran queries) or changed anything?
  • basically can you remember any action you have done since the last time it was working?

Google search on the message "ignoring query … " seems to suggest that you didn’t login to the mysql prompt properly. Check here

mysql -u(username) -p(password) openmrs

show databases;

Yeah… In the same machine only i was working before… I didnt done anything or changed anything yesterday… I have taken backup on 8th march… After that also it was working properly…But from yesterday morning when someone(our staffs) tried to access bahmni,but they cant able to access… Day before yesterday evng also they were working on it…

I am running out of ideas here. :frowning:

What does the above commands tell you? the "ignoring query … " error seems to login issue. Did you try login and checking with the steps above?

Sry for the previous wrong message… Actualy using “mysql -u(username) -p(password) openmrs” i can able to enter and there its showing only information_schema database on show database comment…openmrs db is not there…

I am assuming that you logged in as “openmrs-user”. If the user does not have access to the database, the list will show only “information_schema”.

  • login using root

mysql -uroot -p(password) openmrs

show databases;

If you do not still see “openmrs” database in the above query result, then there can be at least 2 reasons

  1. mysql data directory points to a different place. to check

vi /etc/my.cnf

alternatively, you can also login to mysql prompt and check the datadir variable

show variables where Variable_name = “datadir”;

check where the data directory points to against the “datadir”, by default it would be something like

datadir=/var/lib/mysql

  1. navigate to the datadir, mentioned above and check if there are top level directories representing databases

ls -al (datadir)/

you should have top level directories like “openmrs”, “bahmni_reports” etc in the “datadir”. if you don’t find “openmrs” directory there, then you have a problem - meaning somehow the “datadir” was either “changed” or got “replaced”.

  1. if the “datadir” is different, then check in the default location “/var/lib/mysql”, if you find the top level directories like “openmrs” etc there, then go and edit the “/etc/my.cnf” file and change the “datadir” to point to the right place.

Btw, I am assuming you are doing this on a physical machine and not on vagrant or docker.

1 Like

Any update on this?

1 Like

Im doing in a physical machine not in vagrant… I had checked everything…Its seems like my openmrs database is missing…i dont know how its happened…

Thats weird Mithun.

  1. You should check the OS logs to find out who and when the files were deleted
  2. I am seriously hoping that you had configured either automated backup or at least take regular backup. If so, then try restoring the last backup. If you had active/passive machine setup, then hopefully, you can activate the passive.
1 Like

Yes bro… I have backup…and also i will check logs and all… Thank you for your kind support…