Bahmni installation problems

Hello,

I struggle with installing Bahmni 0.91 on CentOS 7. I tried to follow the install instructions from the wiki but got stuck on the installation of the ansible package. I have installed python 2.6 alongside 2.7 but that does not seem to help. What can I do get a working installation? This is the output I got:

bahmni install
Installing Ansible from https://dl.bintray.com/bahmni/rpm/ansible-2.2.0.0-3.el6.noarch.rpm...
Loaded plugins: fastestmirror, langpacks
Examining /var/tmp/yum-root-20s1yL/ansible-2.2.0.0-3.el6.noarch.rpm: ansible-2.2.0.0-3.el6.noarch
Marking /var/tmp/yum-root-20s1yL/ansible-2.2.0.0-3.el6.noarch.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package ansible.noarch 0:2.2.0.0-3.el6 will be installed
--> Processing Dependency: python(abi) = 2.6 for package: ansible-2.2.0.0-3.el6.noarch
Loading mirror speeds from cached hostfile
 * base: mirror.nl.datapacket.com
 * epel: ftp.nluug.nl
 * extras: centos.mirror.transip.nl
 * updates: mirror.nl.datapacket.com
--> Processing Dependency: /usr/bin/python2.6 for package: ansible-2.2.0.0-3.el6.noarch
--> Processing Dependency: python-crypto2.6 for package: ansible-2.2.0.0-3.el6.noarch
--> Processing Dependency: python-jinja2-26 for package: ansible-2.2.0.0-3.el6.noarch
--> Processing Dependency: python-simplejson for package: ansible-2.2.0.0-3.el6.noarch
--> Running transaction check
---> Package ansible.noarch 0:2.2.0.0-3.el6 will be installed
--> Processing Dependency: python(abi) = 2.6 for package: ansible-2.2.0.0-3.el6.noarch
--> Processing Dependency: /usr/bin/python2.6 for package: ansible-2.2.0.0-3.el6.noarch
--> Processing Dependency: python-crypto2.6 for package: ansible-2.2.0.0-3.el6.noarch
--> Processing Dependency: python-jinja2-26 for package: ansible-2.2.0.0-3.el6.noarch
---> Package python2-simplejson.x86_64 0:3.10.0-2.el7 will be installed
--> Processing Dependency: /usr/bin/python2.6 for package: ansible-2.2.0.0-3.el6.noarch
--> Finished Dependency Resolution
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Error: Package: ansible-2.2.0.0-3.el6.noarch (/ansible-2.2.0.0-3.el6.noarch)
           Requires: /usr/bin/python2.6
Error: Package: ansible-2.2.0.0-3.el6.noarch (/ansible-2.2.0.0-3.el6.noarch)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-77.el7_6.x86_64 (@updates)
               python(abi) = 2.7
               python(abi) = 2.7
           Installed: python36-3.6.8-1.el7.x86_64 (@epel)
               python(abi) = 3.6
               python(abi) = 3.6
           Available: python-2.7.5-76.el7.x86_64 (base)
               python(abi) = 2.7
               python(abi) = 2.7
           Available: python34-3.4.10-1.el7.x86_64 (epel)
               python(abi) = 3.4
Error: Package: ansible-2.2.0.0-3.el6.noarch (/ansible-2.2.0.0-3.el6.noarch)
           Requires: python-crypto2.6
Error: Package: ansible-2.2.0.0-3.el6.noarch (/ansible-2.2.0.0-3.el6.noarch)
           Requires: python-jinja2-26

Thank you.

Bahmni 0.91 is not supported on Centos7. You need upcoming 0.92

Hey,

Thank you for your response. What is the status of the upcoming 0.92?

Beta is already out. We hope to get a release candidate soon (coming week)

1 Like