Bahmni ERP page loading error "--no-js argument deprecated as inline javascript is disabled by default".

Tags: #<Tag:0x00007f78f98a7838> #<Tag:0x00007f78f98a7770>

After installing Bahmni 0.92 and trying to access the ERP module for the first time, an error popped up at the top of the page saying: The “–no-js” argument is deprecated, as inline JavaScript is disabled by default. Use “–js” to enable inline JavaScript (not recommended).

You can see how the error presents itself in the attached image. I tried googling a little bit and a host of different solutions popped up, some saying it was related to memory allocation, while others recommended changing enabling JS by modifying some flag while compiling the stylesheet.

If anyone has run into this issue before and managed to solve it, please reply.

P.S. While installing Bahmni, I followed the steps outlined here: Bahmni Installation on CentOS

@sanjayap

1 Like

Hi @gkesh this is the known issue and has already been mentioned in community. Will let you know once gets resolved. Thanks

@gkesh This is suggesting to downgrade lessc to a version 3.0.4 Use the following command

sudo npm install -g less@3.0.4 less-plugin-clean-css

After installation Restart odoo service. Thanks

4 Likes

Solved my issue Thank you

Thanks @sushantpatil1214, it solved the issue.