bahmni-erp and bahmni-lab not installing and starting

hello i installed bahmni 0.85 on minimal centos 6.7 mutiple times but both erp and lab not installing. i installed both using yum install bahmni-erp and yum install bahmni-lab. Both installed and erp is opening but throwing error whereas lab web page is not opening. showing no web page available. I tried to install pgsql database using restore_pgsql_db() { wget -O pgsql_backup.sql.gz gzip -d pgsql_backup.sql.gz for db in grep "CREATE DATABASE" pgsql_backup.sql |awk ' {print $3}' do echo DROP DATABASE IF EXISTS $db | psql -Upostgres > /dev/null done

psql -Upostgres < pgsql_backup.sql >/dev/null

} but i also throwing error after echo command error > psql: fatal: password authentication failed for user “postgres”

i also installed Postgresql-9.2 with commands

wget rpm -ivh pgdg-centos92-9.2-8.noarch.rpm yum search postgres yum install postgresql92 postgresql92-server service postgresql-9.2 initdb service postgresql-9.2 start chkconfig postgresql-9.2 on and changed vi /var/lib/pgsql/9.2/data/pg_hba.conf ident to trust for host all all and disabled iptables

please help Thanks

Hi Nitin,

Bahmni install will install all the dependents. You don’t need to install anything separately unless explicitly mentioned in Bahmni WIKI. You can confirm if the services like ERP, Lab are started or not by following this wiki page. Can you share your /etc/bahmni-installer/setup.yml file.

Do you have any custom inventory file ? or are you using local that is by default available.

I am using local bahmni -i local install

Hi Nitin, Can you check if the required folder structure for Bahmni-lab, Bahmni-erp as shown in Bahmni WIKI. If yes please check the logs if any exceptions and the status of those services using below commands.

see i have done fresh installation and errors

Thanks for help

Please follow the instructions mentioned on this page

And just to be more precise, you need to perform the steps under Bahmni Installation Failure at task “Remove crontab jobs for upload directories” section.

The first red line in the error you posted is exactly what is being addressed in that section.

But make sure you also set “postgres_repo_rpm_name: pgdg-centos92-9.2-7.noarch.rpm” in /etc/bahmni-installer/setup.yml as described under the Installation failing at “Download postgres yum repo rpm if not present” section.

If you are using 0.85 version of bahmni, then you don’t need this step.

1 Like

troubleshooting method worked fine everything installed without issue but my lab results are not sync with patient dashboard lab results. Lab orders are properly sync from clinical module to ELIS

Did you validate the results in ELIS ?

After collecting the samples and entering the results, you should validate all the results for them to sync back to EMR.

yes i validated results. but still no sync . May be this is due to these alerts and also patient registration id is not displaying in reg slip print, and bar code value remains null

Can you please check if there are any failed_events recorded in openmrs database

Please give more info on this. May be a screenshot helps. Do you have any config changes for the incorporating print functionality according to your needs or are you using existing configurations provided by default ?

how can i check that, till now i haven’t changed a single word in config. Just installed Bahmni an hour back

are you asking about this

Which print page doesn’t show Registration Id ? please share screenshot of that page

Registration Id of Patient

No matter which patient i select. Same barcode appear with null value