Bahmni endTB implementation - certificates installation error in release 1.4


I am installing a bahmni endTB release 1.4 (upgrading from 1.2) following documentation from here: When executing the command “sudo bahmni -i inventory install” , the task is failing when installing bahmni certificates from bahmni repo. Here is the log:

I tried again by executing “yum clean all” and re-running the installer. I still get the error at the same point but the error message this time was different:

TASK [httpd : Install bahmni-certs from bahmni-repo] *************************** task path: /opt/bahmni-installer/bahmni-playbooks/roles/httpd/tasks/main.yml:39 fatal: [localhost]: FAILED! => {“changed”: false, “failed”: true, “msg”: “Failure talking to yum: Cannot find a valid baseurl for repo: base”}

The output for “cat /etc/yum.repos.d/bahmni.repo” is:

[bahmni] name=Bahmni TW Repository for RHEL/ CentOS 6 baseurl= enabled=1

I am installing on CentOS 6.8

Any help is appreciated.

Best, Wasim

Looks like you are not able to access Bintray. Can you please check if you are able to access from your browser? Or else run wget -O - and see if it gives error.

Thanks for your response Jaswanth. I am doing remote deployment. When I did wget on our local server, it connects to the url specified (and also from the browser locally). However, on remote server, wget could not connect. Seems to be the firewall or something on that network not allowing the link to be accessed.

Please check the DNS settings on the remote server. Run cat /etc/resolv.conf. Try to change contents to nameserver and try again.


Changed the dns server. Now able to connect to using wget, however, I am still getting yum error when deploying bahmni.

“fatal: [localhost]: FAILED! => {“changed”: false, “failed”: true, “msg”: “Failure talking to yum: Cannot find a valid baseurl for repo: base”}”

Could you please run dhclient command as per this post

Are you behind a proxy?