bahmni emr requested information error

@swathivarkala i am facing the same issue, what you did to resolve this.

upon inspecting i got the error attached and also i have attached the openmrs log as following

tail -f 100 openmrs.log tail: cannot open `100’ for reading: No such file or directory ==> openmrs.log <== at java.lang.ClassLoader.loadClass(Unknown Source) at org.openmrs.scheduler.TaskFactory.createInstance(TaskFactory.java:51) … 33 more Jul 27, 2017 8:10:38 AM org.apache.catalina.util.SessionIdGeneratorBase createSecureRandom INFO: Creation of SecureRandom instance for session ID generation using [SHA1PRNG] took [6,975] milliseconds. 27-07-2017 08:10:38 [WARN ] OpenmrsUtil - Unable to find a runtime properties file at /openmrs-runtime.properties Jul 27, 2017 8:10:38 AM org.apache.coyote.AbstractProtocol start INFO: Starting ProtocolHandler [“http-nio-8050”] Jul 27, 2017 8:10:38 AM org.apache.catalina.core.ApplicationContext log INFO: Initializing Spring FrameworkServlet 'openmr

Hi, can you try restart? and share the logs?

@swathivarkala i have attached the log file in your Email.

Thank you Sanjay

I also have this error on occasion and so appreciate any information as you continue to address the solution. Thanks.

After making symbolic link- “” Make the user bahmni owner of this new link"" sudo chown -h bahmni:bahmni /var/www/bahmniapps

This worked for me.

@darius i am having the error in my vagrant setup, any ways please. Possible solution.

I had the same error. This solution worked for me too

hello @binduak @sanjayap @swathivarkala @danfuterman @darius

I keep getting this Error -the request information does not exits

Hi @govindsharma, are you able to access https://<ip>/openmrs successfully? Also do you see any error in Openmrs -> Administration -> Modules -> Manage Modules page ??

in browser

Can you show us the list of openmrs modules you have installed?

…run:

cd /opt/openmrs/modules/

and then do

ls -ahl

i done this command cd /opt/openmrs/modules/ then do ls -ahl

In browser same page show

@govindsharma looks like you dont have all the required OMODs that are shipped as part of Bahmni. Can you please try installing again?

@shruthipitta i have installed bahmni again

bhamni -i local install

then after same issue .

Can you share the log file again?

One thing is obvious that the bahmni EMR installation went wrong somewhere for some reason. Please upload the installation logs

You may also try this

service openmrs stop

yum remove bahmni-emr

bahmni -i local install

And then try to see if the OMODs are present in “/opt/openmrs/modules” directory

1 Like

Govind, please don’t post unnecessarily about the same problem in multiple threads. I am seeing the same issue reported by you across many many threads. It does not help you or others who are looking to assist you. Please do a search to figure out which is the most relevant thread to post.

I just saw the log you posted on another thread. If you look at the log, you will see that the issue is with a python package. Googling the error would have brought you better pointers. Anyway …

If its still the same problem you are facing with Bahmni install, try this (on CentOS 6.7 or 6.9)

yum remove python-setuptools
yum install python-setuptools
yum upgrade python-setuptools
easy_install --version 

The last command should show that you have “0.6.10” installed. If so, then go ahead and run bahmni installation again.

Hi,

I used that command in putty Terminal

yum remove python-setuptools
yum install python-setuptools 
yum upgrade python-setuptools

python-setuptools installtion time show version 0.6.10

easy_install --version 

when I used that is show different version (I am useing CentOS 6.9 in server Machine) https://hastebin.com/ifafomapiq.pl

[root@mail ~]# easy_install --version

setuptools 0.7.2

I am having same problem. What is meant by symbolic link? I am hoping that this solution could resolve the problem. I can login into localhost/openmrs and run all the modules including the core bahmni modules.