Bahmni EMR Reports shows Error executing request

Hello Team,

We have one QA server of Bahmni on that Bahmni EMR Reports sometimes gives error as " Error executing request".

All Bahmni Reports configuration is correct and reports run properly, sometimes the Bahmni EMR all reports show “Error executing request”. After that If We restart the Bahmni-Reports service then all reports once again run properly, It’s not happening with any particular scenario or problem is not with any particular one report.

Error get on browser for all reports:

I have checked the Bahmni reports logs, Logs are here

In the log says that

Caused by: peer not authenticated

Is this problem is causing due to SSL certificate is not added, As this is QA server therefore SSL certificate is not added, we use a Bahmni with server IP.

Is anyone has faced this issue earlier like sometimes Bahmni EMR reports stop working? Any suggestions for resolving this issue.

What is the JRE you are using?

Hello @buvaneswariarun,

I am having JRE: 1.8.0_131

Adding more info, I am using Bahmni 92.

Hello @amolsatvix

Did you find a solution for this? We sometimes experience the same issue in our PROD and we have to restart the reports service

we have seen this being reported intermittently. usually restarting the reporting service works.


did anyone find a solution for this?

@angshuonline maybe?

We haven’t seen this being reported recently. Which version of Bahmni are you using? restarting didnt help?

@angshuonline This is the tomcat issue that we solved in 0.93

A client reported this error today on a 0.93 version.

@binduak @rohit.yawalkar @deepthi

@jaghatise is the issue still there on the env ? or its already resolved ? If its resolved what are the steps that you have followed to fix the issue ?

@binduak we simply restarted the system and it solved it. I have not had time to visit the facility to zero down on possible cause.

This issue was resolved in BAH-1149 and released with V0.93.

The demo v93 is available here: Please see if you can reproduce issue here. Or, check if the v93 version has the right rpms installed on your side.


1 Like