Bahmni down for maintenance

Hi, I’ve recently installed bahmni in my newly installed centOS, but when I accessed “http://machine-ip/home” or any “http://machine-ip/” links it says “Down for maintenance”, please help me or guide me, why I got this error or page, I just followed all the instructions in here: https://bahmni.atlassian.net/wiki/display/BAH/Install+Bahmni+on+CentOS

Moved to #software:bahmni category

I also have this problem when installing CentOS on my server-grade PC.

“Down for maintenance”.

Hi @thecugoteen, Can you check openmrs service is up and running. Also send a screenshot of the contents of /var/www/html folder.

This is the services that are running and openmrs is running, while openerp, bahmni-reports, atomfeed-console are not.

and this are the contents of my /var/www/html folder

. Sorry for the late reply, I’ve been busy for the last couple of days.

Hi @thecugoteen, Can you delete the maintenance.enable file from /var/www/html path and try. This file should have deleted as part of the installation. We have a mingle card to fix the issue. You can track status of the card here.

Thank you so much, it works, but i have other issue, i will post another tread. thank you so much

@binduak @darius As this topic is already mentioned here I would like to continue instead of creating new topic.

Every time I run backup that is complete backup or incr backup than maintenance.enable file gets added and then it should get removed automatically , but it does not get removed and I face the issue as Down for maintenance and I need to remove that file manually. And when it gives message as down for maintenance than does ERP work fine or it also has any issue? I have never faced this issue before. So for workaround I removed backup from cron and now I dont get this issue. But I need system to take backup frequently. So need solution which would be more precise.

I am Using bahmni V 0.90 and I have installed bahmni on Local CentOS machine.

It looks like this card was not completed, is that right @binduak?

We should migrate this card to JIRA (manually is fine) and see if someone wants to pick it up and fix it.

Its not the issue with installation. When dbBackup/dbRestore doesn’t went well because of any reason, it doesn’t delete the maintenance.enable file. And this is a valid case.

@nawazshaikh, are you sure the backup/restore was successful in your case. Can you check without cron job and confirm. Because we see maintenance.enable file not getting removed only when backup/restore command fails.

Hi binduak Yes the backup is not successful. Both with or without cron. But why is backup not getting successful. I have used below command to backup.

bahmni -i local backup --backup_type=all --options=all.

When I have seen log , I found that openmrs backup is happening properly but postgres_backrest.log and bahmni-postgres-backup.log shows that backup of pgsql (OpenERP) succeded only once and all the subsquent backups failed on archiving all WAL segments after waiting for 30 min.

yes…Its more of issue with Backup/Restore Command. If possible can you start a new post with detailed description.

I have faced this problem. I have tried the above but it seems not to work for me. I am running the v.90. Help Plese.

I am also facing Bahmni Down for maintenance problem .I have tries the above but seems not work from me ,i am ruuning Bahmni in centOS 6.9 please help me

HI @govind Can u try by deleting maintenace.enabled from the path /var/ww/html.