Bahmni-core 0.93 build and deploy issue

Hello, we set up an instance of bahmni 0.93 in a local vagrant box following the instructions in the bahmni wiki, and it worked perfectly. Setting up the front end code also worked fine for front end development, but we kept getting an issue when we tried to deploy bahmnicore-0.93-SNAPSHOT.omod backend module. We cloned the bahmni-core repository release-0.93 branch from github and we built it following the instructions in the readme file. We set up the prerequest software accordingly and the maven build was successful. We swapped out the original module with the newly generated “bahmnicore-0.93-SNAPSHOT.omod” and tried to restart the openmrs service, but when we opened the openmrs page, we were met with an error message informing us that openmrs was not able to start, and both the openmrs admin page and clinical page were down. When we tried to see the log file, it showed that the openmrs had failed to find some classes. In the end, we luckily stumbled across the source of our problem. The problem was the difference between the bahmni-core repository used in the official vagrant box and the one we got when we cloned the project from github. There are some commits added to the project after the 0.93 vagrant box was released, so when we checkout the github repository to the verified commit level, which is commit BSL-9 | Retuning 403 forbidden, also returning an error object with m… · Bahmni/bahmni-core@2f5ae97 · GitHub then it works fine. But when we built the module and deployed it for the first time, we got an issue which we finally solved by removing all files inside /opt/openmrs/.openmrs-lib-cache/ directory and restarted openmrs. We don’t know if there is any consequence to using this approach to solve this problem. We would be very happy if you could suggest a better way to solve this issue. Notice: We didn’t modify any code; we used the original repository. We didn’t get this issue before, when we used bahmni 0.92.

Hi, We have been facing the same problem when building the bahmni-core for 0.93. In addition, maven clean install takes too much time to build the project. We have also tried to build the specific modules, but it is the same. Is there any solution? @angshuonline did you guys face any issues while building and deploying the current bahmni-core 0.93 release from the GitHub repo and can you give your opinion on the @saidmurad post?

@binduak we were facing cache related issue while running integration tests, right? Although wee didnt have any problem runtime … do you think this might be related?

Btw, there has been a new release 0.93.2 version. I think the vagrant box is yet to uploaded.