Bahmni Connect does not appear on UI

Hi, i have installed bahmni connect as mentioned here but i cannot see it on the homepage.

Please i need your help, thank you.

He @jess, Try out this Link. It might just be the one you need.:+1:


@kazlaw yes i try it

when i install bahmni -i local install odoo failed to start i get this error [root@localhost bahmni-erp]# service odoo restart Restarting odoo (via systemctl): Job for odoo.service failed. See “systemctl status odoo.service” and “journalctl -xe” for details. [FAILED] Please do i need to open another ticket for this issue

do i need odoo to install bahmni connect…

No… Bahmni Connect doesn’t need Odoo.

See this page:

Why are you wanting to use Bahmni Connect? Can you provide some details about your requirements/use-case?

@gsluthra i install bahmni for a medical research center so we need bahmni connect in order to register patients even if we do not have internet connection or we are out of the center with tablets.

Sounds fair. You can also consider deploying Bahmni on cloud (in your country/AWS/DO), and therefore access it over internet wherever you are. Security/Complaince considerations although needed.

Alternatively, connect to Bahmni server, via VPN from your tablet/desktop to research center, and then access Bahmni.

You can try bahmni connect too, note that it has certain restrictions – registration + clinical. It hasn’t been adopted too widely, most people prefer online Bahmni over using connect.

@gsluthra via the VPN it is also a good idea, bahmni connect i really need it in the case we register some patients where the internet connection is not available.

@gsluthra i followed the steps described here but still the Bahmni connect is not visible. i add bahmni-offline module into that path /opt/openmrs/module and install bahmni-event-log-service which is running s you can see below

Please any idea on how to make it work.

it works now!!! i solved it by adding in the inventory file this 2 lines [bahmni-event-log-service] localhost and [bahmni-offline] localhost.


I face another issue for the location but it will be the subject of another thread.


I guess after adding those two lines in Ansible Inventory file, you executed bahmni installer again, so that it installed those two components. Correct?

1 Like

@gsluthra yes you are right