Bahmni Connect Android Apk Error

Hey guys,I am working on bahmni connect and i have compiled the apk and deployed it on my phone.After opening the app it shows the initial page where I have to enter the ip address of my server.

After entering the ip , it shows the spinner and says Offline Content being synced
and it gives an error saying “The requested information does not exist”.
Upon inspecting the error using “chrome://inspect/#devices” I get 2 errors:

1.file:///android_asset/www//bahmni_config/openmrs/i18n/offline/locale_en.json net::ERR_FILE_NOT_FOUND
2. /sql/globalproperty?property=allowMultipleLoginLocation 404 (Not Found)

In error 2,if i go to the said Ip address it works.Dont know why it says 404.I hope someone helps me out as its an urgent problem that needs to be taken care of

Hi @krishnanspace,

please follow Customizing Bahmni Connect for error 2

For error 1 can you ran bahmni -i local concat-configs

Thanks.I’ll try it out and let you know

I ran bahmni -i local concat-configs,but I still got the same error

have you checked file/folder permissions?

No problems with the file permissions.Here are the permissions for the folder:
drwxrwxr-x 6 root root 4096 Feb 22 17:32 bahmni-offline/

@krishnanspace , not sure how much my issue is related to yours (especially your point 1/) but I have compiled the APK and pushed it on my phone too (though the APK name generated by Cordova is '“android-debug.apk” for some reason).

Now as soon as I start the app, I get the following error message:

Not sure where to look at since the message is truncated.

I have run this through Android Studio and got quite a lot of errors in the log but I am no expert on Android (yet).

Any idea?

Sorry for the late reply, I had encountered the same problem. To solve that : Go to config.xml and change the <content src> tag from"…" to index.html

1 Like

Is the setup steps of the android app still valid? The above issues are still there. Fixed the location in config.xml file as well but still I get the same issues.

Yes , they are still valid. Still works for me