Bahmni Application failed to run on my browser

I have installed the Bahmni installer on CentOS 6.7 i386. I am trying to have a demo on a computer before I present to some group of medical students. However, I ran into some challenges while i tried to run the application on my browser. My computer has the following specifications installed CentOS 6.7 i386 which is for 32 bit computer. This is because the computer is 32 bit and can only accept CentOS 6.7 i386 (32 bit)) Computer CPU has Core™ 2 Memory is 2 GB RAM Hard disk space is approx. 150GB.

Could these information be the reason why the Bahmni application didn’t run on my browser?

Please I need an answer.

Thank you!

Could you please explain more on the errors that you faced? Is the installation successful? Or are you facing errors while running the application?

Yes I think the Installer went well but the application failed to run on the browser. It keeps showing “errors trying to open this page” on the browser. or how else can I access the application after installing the installer ?


can you try to open OpenMRS /openmrs? Check status of all services following Bahmni WIKI.


Which browser are you using? Could you please send the version of the browser?

I tried to run it on Firefox and chrome but it failed. Could it have run on my computer despite the specifications I stated above?

Follow these steps to troubleshoot:

  • Check whether OpenMRS is running fine or not. Run service openmrs status in terminal. Also, visit http://localhost:8050/openmrs (Substitute localhost with the ip address of the server, if required).

  • Collect few lines of OpenMRS logs. Run tail 300 /var/log/openmrs/openmrs in a terminal. Please send the output.

  • If you are able to access OpenMRS, but not Bahmni UI, check the version of Chrome you are using. Put chrome://version in the address bar and send the version. Bahmni only supports Chrome web browser.

Thank you. I had to reinstall it on another machine with bigger and better specifications. But I still think something is not right. After I installed it on the machine, it worked fine and I was able to visit the applications at first but for two days now I have been getting this weird message “Down for maintenance - sorry for the convenience, we understand that this could be impacting patient care. Please re-visit in a few minutes” Is it something normal ?

I will appreciate your response.

Hi @femilee078, Can you check if all the services are up. If all the services are up and running but still if you see the Maintenance page, please go to /var/www/html/ folder, you will find the Maintenance page. Please remove it from there.

Thank you for your response. Please how do I get to the /var/www/html/ folder? I am not a guru in this. Please forgive my ignorance.

I found it but please how do I remove it from there ? is there a command I could use ?

Please use the below command.

I tried it but it still didn’t work

Yes It worked !!!. Thank you

Do you have the application working now?