Bahmni 0.92 on CentOS 7.6 - Odoo page not reachable

Hi Folks,

Newbie here - first time setting up Bahmni. It went spendidly on the installation side. There were no errors, staus check revealed most of the services were running. Those that weren’t running, I got them started manually. Service%20Status Upon checking, the EMR, OpenELIS and OpenMRS components were accessible using the URLs on the installation page. The Odoo component on port 8069 refused to load, though. I tried it on two separate servers with the same result. Doesn’t seem to be a problem with the service as the logs show its up and running. Any advice on how to handle it?

Here’s a screenshot of the Odoo page.Odoo @angshuonline

you probably need to allow access to 8069 port. by default only port 80 and 443 would be.

Easy way to check is to disable iptables! (which you should not do on general/public/production)

or something like

iptables -A INPUT -m state --state NEW -p tcp --dport 8069 -j ACCEPT

(this might require your SELINUX policy to be changed first).

You should figure out how you want to provide access to Odoo. For example, we use Apache to reroute call on a particular subdomain thats mapped to Odoo (like You can do the same.

1 Like

Thanks @angshuonline! Opening the port did the trick. I’m able to reach the page now.