bahmni 0.92 on centos 7.6 fails after trying installing dcm4chee and pacs integration

Hello Team, i tried installing the above two modules but when i ran the command bahmni -i local install i get this output error TASK [bahmni-emr : Start openmrs] *********************************************************************************************************************************************************** task path: /opt/bahmni-installer/bahmni-playbooks/roles/bahmni-emr/tasks/main.yml:218 fatal: [localhost]: FAILED! => {“changed”: false, “msg”: “Unable to start service openmrs: Job for openmrs.service failed because the control process exited with error code. See “systemctl status openmrs.service” and “journalctl -xe” for details.\n”} to retry, use: --limit @/opt/bahmni-installer/bahmni-playbooks/all.retry

PLAY RECAP ********************************************************************************************************************************************************************************** localhost : ok=134 changed=50 unreachable=0 failed=1

Traceback (most recent call last): File “/bin/bahmni”, line 9, in load_entry_point(‘bahmni==0.1’, ‘console_scripts’, ‘bahmni’)() File “/usr/lib/python2.7/site-packages/click-7.1.2-py2.7.egg/click/core.py”, line 829, in call return self.main(*args, **kwargs) File “/usr/lib/python2.7/site-packages/click-7.1.2-py2.7.egg/click/core.py”, line 782, in main rv = self.invoke(ctx) File “/usr/lib/python2.7/site-packages/click-7.1.2-py2.7.egg/click/core.py”, line 1259, in invoke return _process_result(sub_ctx.command.invoke(sub_ctx)) File “/usr/lib/python2.7/site-packages/click-7.1.2-py2.7.egg/click/core.py”, line 1066, in invoke return ctx.invoke(self.callback, **ctx.params) File “/usr/lib/python2.7/site-packages/click-7.1.2-py2.7.egg/click/core.py”, line 610, in invoke return callback(*args, **kwargs) File “/usr/lib/python2.7/site-packages/click-7.1.2-py2.7.egg/click/decorators.py”, line 21, in new_func return f(get_current_context(), *args, **kwargs) File “build/bdist.linux-x86_64/egg/bahmni.py”, line 79, in install File “/usr/lib64/python2.7/subprocess.py”, line 542, in check_call raise CalledProcessError(retcode, cmd) subprocess.CalledProcessError: Command ‘ansible-playbook -i /etc/bahmni-installer/local all.yml -vv --extra-vars ‘@/etc/bahmni-installer/rpm_versions.yml’ --extra-vars ‘@/etc/bahmni-backrest.conf’ --extra-vars ‘@/etc/bahmni-installer/setup.yml’’ returned non-zero exit status 2

any help on this. Thanks Apuda

probably because of click version mismatch.

pip uninstall -y Click

pip install “Click==7.0”

also, as mentioned in our release notes, you might need another lib (if you are using odoo)

pip install beautifulsoup4

@angshuonline, thanks for the fast response to this challenge,i tried running the commands unfortunately, the same error is output ,should there be another limiting factor failing the bahmni install to complete successfully?. looking forward for your response. Thanks

i came across the same challenge… the discussion is here Error installing the Bahmni 0.92 on CentOS - #6 by yeowsen

I am not sure if your scenario is exactly the same as the mentioned thread. However, try this

  1. Upgrade Zlib

yum install https://kojipkgs.fedoraproject.org//packages/zlib/1.2.11/18.fc30/x86_64/zlib-1.2.11-18.fc30.x86_64.rpm

  1. Check the python packages. Pip version should be 19.0 or above. Click=7.0, and beautifulsoup4=4.9.3.

pip --version

pip freeze | grep Click

pip freeze | grep beautifulsoup4

Also, note the error is saying that service openmrs are unable to start. So try to check whether the service was installed

systemctl list-units --type=service

check for openmrs service. Also check journalctl service log for openmrs service

journalctl -u openmrs

check the logs. they might provide you with further details btw, you needn’t run the install again. Just do openmrs service restart to verify whether the openmrs service starts up.

systemctl stop openmrs

systemctl start openmrs

But if the issue to me seems to be with click version, from the log the version is 7.1.2

Thanks for the reply to my challenges, i have tried the above steps invain, the same error persist. i

pip version attached are the screenshot of the command output. is it okay to upgrade the click version or it will still throw in the same errors, and also, how can i unistall both dcm4chee and pacs integration Thanks @angshuonline

I don’t think the installation of EMR went properly. (look at the msg for logdirectory … it should be set). Can you try uninstallating and reinstalling EMR again? Lets just tackle one thing at a time - starting with EMR.

yum remove bahmni-emr

bahmni -i local --only bahmni-emr install

btw, check what version of ansible you have. should be 2.4.6

ansible --version

Also can you say which CentOS distro you are using? Can you also try with CentOS minimal …

Thanks so so

much @angshuonline it has worked however, checking both the status of atomfeed-console and pacs-integration shows not running with this screenshots what could be the challenge here? Thanks

from the log of atomfeed-console, it seems the runuser command is not present in the expected path. (thats why I asked which CentOS distro you are using) find out where the runuser is, and create a symlink under a path discoverable by the OS.

whereis runuser

the CentOS distro iscentos version and the runuser is found here runuser

So, just create a symlink (do as root) in the location

ln -sf [source] [destination]

Good morning here in Karamoja Uganda @angshuonline , I did the runuser symlink like this ln linking and still atom feed console not running, all other services are running fine. take a look at this

error is at line 22 with a green mark. Thanks in advance

I dont think the runuser.gz is an executable file. I would assume the file under /usr/sbin/runuser to be the right one!

I really don’t Know…Pacs-Integration also has entered into the same challenge…

Hello @angshuonline , i managed to figure out the issue with atomdeed console, i had to uninstall and re-install it Thanks so much for the efforts. The unfortunate part is i dont see lab results sync back to patient dashboard and more so xray request sync to dcm4chee module… i dont know why is this trouble