atom feed error when sync between openmrs and openelis

Is it okay you have a call with @yusto ? he seems so frustrated with the blocker. Kindly help him out.

I wouldn’t want to encourage this, as we have limited time for such 1-1 interactions. He can join the core team standup tomorrow and if we have time, we will try to help him.

@dkayiwa am sorry for bothering. Kindly help @yusto with his blocker.

@jwnasambu if you did not know, @angshuonline is one of the bahmni experts that we have in our community. So, following his advice, is key to getting this resolved in a sustainable way.

1 Like

I didn’t know that. I was just looking at the urgency of @yusto assuming he is implementing bahmni . @angshuonline I believe he is the safe hands and I go with your suggestion.

This helped me… I made sure My panel was added into “sample”, “department”, all_tests _and_panels. So Far I added 5 Lab test and worked without any errors!

Quick Question: Is naming a concept (lab test )with a name with “&, /, -” e.g Blood group & RH Factor does it cause problems?

after setting several test am getting this and I did exactly like other… Test ‘HBsAg’ was not setup properly. No external reference for Test with uuid ‘7d8bc350-3414-495a-b7f8-73b96a37de7b’ found in external_reference table java.lang.RuntimeException: java.lang.RuntimeException: Test ‘HBsAg’ was not setup properly. No external reference for Test with uuid ‘7d8bc350-3414-495a-b7f8-73b96a37de7b’ found in external_reference table

Still get ting errors I have no Idea where am doing it wrong!

  • I follow same procedure with no success

2020-02-19 07:14:30,048 ERROR [ELIS][AtomFeedClient] Failed to process failed event. FailedEvent{failedAt=1582096320074, event=Event{id=‘tag:atomfeed.ict4h.org:c65a4a4a-ce42-4a65-a6a4-a255ceaf6053’, content=’/openmrs/ws/rest/v1/reference-data/department/4345e76b-bc6f-4b9c-ad5a-1fe23ca2752a’}, errorMessage='Failed processing event in feed [http://localhost:8050/openmrs/ws/atomfeed/lab/5] us.mn.state.health.lims.common.exception.LIMSRuntimeException: Error while saving Department - Haematology Departmentjava.lang.RuntimeException: us.mn.state.health.lims.common.exception.LIMSRuntimeException: Error while saving Department - Haematology Department at org.bahmni.feed.openelis.feed.transaction.support.AtomFeedHibernateTransactionManager.executeWithTransaction(AtomFeedHibernateTransactionManager.java:51) at org.ict4h.atomfeed.client.service.AtomFeedClient.processEvents(AtomFeedClient.java:68) at org.bahmni.feed.openelis.feed.job.OpenELISFeedReaderJob.processEvents(OpenELISFeedReaderJob.java:73) at org.bahmni.feed.openelis.feed.job.OpenELISFeedReaderJob.execute(OpenELISFeedReaderJob.java:57) at org.quartz.core.JobRunShell.run(JobRunShell.java:207) at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:560) Caused by: us.mn.state.health.lims.common.exception.LIMSRuntimeException: Error while saving Department - Haematology Department at org.bahmni.feed.openelis.feed.event.LabFeedEventWorker.process(LabFeedEventWorker.java:95) at org.ict4h.atomfeed.client.service.AtomFeedClient$EventProcessor.doInTransaction(AtomFeedClient.java:168) at org.ict4h.atomfeed.transaction.AFTransactionWorkWithoutResult.execute(AFTransactionWorkWithoutResult.java:6) at org.bahmni.feed.openelis.feed.transaction.support.AtomFeedHibernateTransactionManager.executeWithTransaction(AtomFeedHibernateTransactionManager.java:42) … 5 more Caused by: us.mn.state.health.lims.common.exception.LIMSException: Error while saving Department - Haematology Department at org.bahmni.feed.openelis.feed.service.impl.TestSectionService.createOrUpdate(TestSectionService.java:87) at org.bahmni.feed.openelis.feed.event.LabFeedEventWorker.process(LabFeedEventWorker.java:76) … 8 more Caused by: java.lang.NullPointerException at org.bahmni.feed.openelis.feed.service.impl.TestService.updateTestSection(TestService.java:195) at org.bahmni.feed.openelis.feed.service.impl.TestSectionService.updateTests(TestSectionService.java:93) at org.bahmni.feed.openelis.feed.service.impl.TestSectionService.createOrUpdate(TestSectionService.java:85) … 9 more ', feedUri=‘http://localhost:8050/openmrs/ws/atomfeed/lab/recent’}

  • I guess the error appears when populating this Tab or when adding

  • When collecting Sample

Lets catch up during standup 2:30 pm IST. Please check our WIKI for standup details.

1 Like

alright then

sorry, but I got caught up with some urgent work today, and wouldn’t have much time during today’s standup? Can we instead meet tomorrow at 2:00 pm IST, on the same standup zoom meeting?

sure no worries… am holding into that

Hey, I would love to have Meeding ID or link

We can meet at 2:00 pm IST (830 am UTC). Which is about 5 mins from now.

I think you connected to the wrong zoom. and when you connected back to the right zoom meeting, I dont think your microphone was connected. anyway, I wanted to get this done before the standup. Lets try to do this over the same zoom id on Monday 2:00 pm IST.

if you dont have zoom, then send me a hangout link or so for Monday at that time.

I had connection issue will join you in 5 mins

Still no Success:

{ “categories”: [ { “scheme”: null, “label”: null, “schemeResolved”: null, “term”: “lab” } ], “id”: “tag:atomfeed.ict4h.org:09ea234c-2050-4970-bd32-cfd16eeecf43”, “content”: “/openmrs/ws/rest/v1/reference-data/department/e72f16a7-ced4-4fce-bfd1-dd23da936333”, “feedUri”: null, “updatedDate”: null, “title”: “department”, “dateCreated”: null }

Please put the entire log. this is just the event. you need to see the log, errors in the following places

  • corresponding entries in database table “openmrs.failed_events”, and “openmrs.failed_event_rety_log”
  • in log file /var/log/openmrs/openmrs.log
1 Like