Appointments Module not working after Bahmni 0.93 release

Dear community,

may i ask for help or clarification:

It looks like since Bahmni v0.93 was released (25.10.), the appointments module does not get installed properly on the latest Bahmni v0.92 (155):

I looked in our dev environment from 09.09. and there was a version appointments-1.1.2-SNAPSHOT.omod in /opt/openmrs/modules and loaded in the openmrs UI and working. After reinstalling v0.92 appointments-1.2.0.omod is installed but not loaded in openmrs UI.

FYI: Looks like the omod is really not loaded - at least for my installations…

Caused by: java.lang.ClassNotFoundException: org.openmrs.module.appointments.scheduler.tasks.MarkAppointmentAsMissedTask

Also the previous 1.1.2-SNAPSHOT version had around 133kB whilest the 1.2.0 does only have 91kB - looks likes only was distributed?

Maybe has some hint for me.

BR, Johannes

1 Like

At least i found this error in the log:

29-11-2021 11:18:13 [ERROR] ModuleFactory - Error getting module object from file appointments-1.2.0.omod
org.openmrs.module.ModuleException: Error loading module, no config.xml file found. Module: appointments-1.2.0.omod
        at org.openmrs.module.ModuleFileParser.parse(
        at org.openmrs.module.ModuleFactory.getModuleFromFile(
        at org.openmrs.module.ModuleFactory.loadModule(
        at org.openmrs.module.ModuleFactory.loadModules(
        at org.openmrs.module.ModuleFactory.loadModules(
        at org.openmrs.module.ModuleUtil.startup(
        at org.openmrs.api.context.Context.startup(
        at org.openmrs.web.Listener.startOpenmrs(
        at org.openmrs.web.WebDaemon$

How did you install appointment over 0.92? Did you just pull the frontend and install? You need to also replace the appointment omod with the latest, that will come bundled with the main distro. Assuming you just pulled the latest appointment UI over 0.92

  1. the new UI usually points to “https://your-serverr/appointments-v2/”
  2. Download the appointment OMOD from here -

I just ran yum install -y and there was still this error also on appointments-v2 url:

and unfortunaltely the maven repo only contains poms…

Hey Johannes, We are investigating, will get back to you in a day.

check /opt/openmrs/modules directory and replace the omod with the 1.3.0 version mentioned above.

@rohit.yawalkar thank you


You mean from here and build?

Because i tried that already…

And in your link

is no omod - maybe you can give me a hint how i can get it from the pom?

Thanks, Johannes check the files section - download the jar and rename the extension .jar to .omod

Thanks but unfortunately now the whole UI won’t start…

  1. did you remove the older omod? there can be only 1 version of omod
  2. although, appt is pretty independent - we havent tested new appt with 0.92 … pls provide us the logs

Dear @angshuonline and @rohit.yawalkar,

Thank you very much for your fast answers.

I found out that a plain installation (briefly section)( without our internal script worked out.

For the sake of completeness, i attach my logs - maybe you want then anyway.

Working with a plain installation without our internal script should workout for me for now - therefore i consider this issue as completed.

Thanks again and for your support!

1 Like