Appointment Scheduling is Broken On Openmrs Demo Instance

Did any one notice that Openmrs Demo Appointment Scheduling is Broken ?

Steps to reproduce

  1. Login to Openmrs Demo Instance
  2. Go to Appointments Scheduling -> Manage Appointments
  3. Search by ID or Name
  4. Choose a patient Empty page is displayed.

Yes @sravanthi17 ,its a community priority ticket on Jira .Here is a link to the same : https://issues.openmrs.org/browse/AM-184 .

Thanks @reubenv

There is one more issue using Appointment Scheduling via Login

I get the following error when scheduling an appointment.

Steps to reproduce.

  1. Go to Login
  2. Click on Schedule New appointment
  3. Click on submit

You may temporarily access it by modifying the url a bit i.e in url , remove anything within the breadcrumboveride part so it should basically look like this

(https://demo.openmrs.org/openmrs/appointmentschedulingui/manageAppointments.page?patientId={the patient-id you want to browse}&breadcrumbOverride=[remove everything in here] ).

This basically removes the breadcrumb part of the page but this tiny hack makes it usable until the issue is fixed.

Thanks @reubenv This temporarily solves the issue. I can now access the page

I have been able to reproduce this issue but I’m not sure about the cause(I believe the error being shown in the log is not the cause). Maybe @darius , @dkayiwa could help?

@reubenv do you mean what was fixed here? https://github.com/openmrs/openmrs-module-appointmentscheduling/commit/86936c058f2f789ccf468a62039807b756df4f06

Yes @dkayiwa ;-). By the way how often is the demo server updated to include the latest code?

Demo server is up to the next release of the referenceapplication. Latest code is always run here qa-refapp.openmrs.org

While trying to install Appointment Scheduling, the module Core Apps isn’t starting with below mentioned error

Where do I find appui 1.7 ? As per OpenMRS Add Ons 1.5.1 is the latest version

appui was released according to https://github.com/openmrs/openmrs-module-appui/tree/1.7 I just did not have the permission to upload it to modulus. You would then get it from nexus (did i say JFrog or Bintray?) :slight_smile:

Any idea when that can be uploaded ?

@wyclif @mogoodrich @darius have the needed permission.

Or even addons-stg.openmrs.org :wink:

@sravanthi17, we have an SSO outage right now so I can log in upload the module.

But you can get it from https://openmrs.jfrog.io/openmrs/webapp/#/artifacts/browse/tree/General/omods/omod/appui-1.7.omod (direct link: https://openmrs.jfrog.io/openmrs/omods/omod/appui-1.7.omod)

Thanks @darius. That Worked.

I have successfully installed the appointment scheduling. when I access openmrs/appointmentschedulingui/home.page I get the following error.

org.openmrs.ui.framework.ViewException: (in ‘decorator/standardEmrPage’) *** In view ‘header’, NullPointerException: Cannot get property ‘uuid’ on null object.

Any idea why this is happening ? From the log, I could see that configSetting is null

I think it’s the same problem I responded to here: UI Framework Error: NullPointerException: Cannot get property ‘uuid’ on null object.

(you need a session location, and perhaps you logged in via the OpenMRS Legacy UI’s login screen, which doesn’t require one.)

As Darius suggested here , building https://github.com/openmrs/openmrs-module-appui module solved the problem.

@dkayiwa when will the latest appointment scheduling omod with the fix be available?