Announcing Bahmni 0.92 Release Candidate

Thanks, I have responded here

Thanks @angshuonline, the issue with invalid characters was resolved.

Is there a solution for this one

I followed this workaround but it did not work

I get this error message when I run systemctl status openmrs.service

New main PID 1463 does not belong to service, and PID file is not owned by root.

And this when I run systemctl start openmrs

Job for openmrs.service failed because a configured resource limit was exceeded. See "systemctl status openmrs.service" and "journalctl -xe" for details.

Hello @stephencoduor, were you able to resolve the odoo problem? May you please share how you resolved it because I am facing the same issue

Hello @angshuonline, any idea why this is happening?

service odoo status
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
mkdir: cannot create directory ‘odoo’: File exists 

I also noticed that openerp database was not created

postgres=# \l
                                   List of databases
    Name     |  Owner   | Encoding |   Collate   |    Ctype    |   Access privileges
-------------+----------+----------+-------------+-------------+-----------------------
 bahmni_pacs | postgres | UTF8     | en_US.UTF-8 | en_US.UTF-8 | =Tc/postgres         +
             |          |          |             |             | postgres=CTc/postgres+
             |          |          |             |             | pacs=CTc/postgres
 pacsdb      | postgres | UTF8     | en_US.UTF-8 | en_US.UTF-8 |
 postgres    | postgres | UTF8     | en_US.UTF-8 | en_US.UTF-8 |
 template0   | postgres | UTF8     | en_US.UTF-8 | en_US.UTF-8 | =c/postgres          +
             |          |          |             |             | postgres=CTc/postgres
 template1   | postgres | UTF8     | en_US.UTF-8 | en_US.UTF-8 | =c/postgres          +
             |          |          |             |             | postgres=CTc/postgres

This problem (resource limit exceeded issue) still persists in our new deployments , actually this is the blocker issue for us to go for production implementations.

@angshuonline can we prioritize this issue ?

cc: @utsavdeshar | @deepakneupane | @sanjayap

1 Like

Can you tell me what version of Centos7 are you using?

cat /etc/centos-release

I started investigating that, and came across similar error on CentOS7.7. I am wondering if its relevant to a reported issue https://access.redhat.com/solutions/4397951

Can you try with CentOS 7.6 or 7.5?

Don’t use “systemctl status openmrs”. Depending on your Systemd version, I think you will come across this problem. https://access.redhat.com/solutions/4397951

use

service openmrs start

Local Setup - Master - Slave

Installer Version - 0.92-142

I still see these errors in ODOO.

Though ODOO works fine on master but patients do not sync from Bahmni to ODOO. bahmni-erp-connect is running fine and markers as well as failed_events are empty on both openmrs and odoo databases.

On slave, ODOO is showing this jquery error which is surprising as this being a master - slave setup and slave db should have been exact copy of master, right?

Hi laxman,

I replied on another thread regarding the same issue - you could find it here.

this was because this entire section was missing in the file that got installed. This needs further investigation on our side.

I also noticed that the installation puts openelis parameters only if bahmni-lab is to be installed whereas none of the attributes are optional in this OpenERPAtomFeedProperties.java class.

So we may have to test installing without bahmni-lab if bahmni-erp-connect runs normally or does the file erp-atomfeed.properties need manual modifications?

Bahmni ERP Connect should work irrespective of whether LAB is installed or not. the Feed URLs of the lab should be blank, which makes the feed consumer ignore it.

Hi @angshuonline , when I change odoo password from the default admin username and password, bahmni does not send orders to odoo. When I revert back the to the default everything works again

Is anyone experiencing this? Must the password remain as the default

Need to update the changed username and password to file path /opt/bahmni-erp-connect/bahmni-erp-connect/WEB-INF/classes/erp-atomfeed.properties on odoo section: openerp.port=8069 openerp.host=localhost openerp.database=odoo openerp.user=admin(default) openerp.password=admin(default) for sync from openmrs to odoo.

Thats because “admin” is the user that was used for integration.

To do this, you need to

  1. shut down the “bahmni-erp-connect” service
  2. modify the file “/opt/bahmni-erp-connect/bahmni-erp-connect/WEB-INF/classes/erp-atomfeed.properties” and modify the properties - “openerp.user” and “openerp.password”.
  • there are other ways of modifying such runtime properties. Check the WIKI documentation here
  1. restart the service.

When I try to sync Bahmni with Odoo I get this error

This happens when I click the Bahmni Atom Feed app in Odoo. Also when I try to access AtomFeed Console from Bahmni home i get below error

Not Found

The requested URL /atomfeed-console was not found on this server.

Have you tried restarting the services

systemctl restart bahmni-erp-connect

systemctl restart odoo

I have tried it already, I still get the same error

Is your odoo instance running? Have you tried accessing the odoo frontend, and does that work well? From the log, I can see that its saying the Odoo module “bahmni_atom_feed” load failed, because of ir.model.access.csv could not be processed. Maybe the installation was not right?

Have you tried reinstalling Odoo?

yum remove bahmni-erp-connect

yum remove odoo

bahmni -i local --only bahmni-erp-connect, bahmni-erp install

I am a bit hesitant to uninstall and re-install because I struggled to get to where I am at the moment. Yes Odoo is running and I can access the front-end. I was getting this error while trying to install the App from the front-end

@angshuonline I uninstalled Odoo and re-installed it but I still get the same error message

@tapologo you don’t have to uninstall odoo, just the bahmni-erp-connect. First up, can you just restart bahmni-erp-connect?

systemctl restart bahmni-erp-connect