Admin login failed after setup

Hi. I have implemented openmrs 2.4 for the first time. Afther the initial setup i try to login and I automaticly directed to the Addon manager. I tried to login with the admin account but i get an error. I used al know passwords (test, Admin123 and the password created in step 4 of the configuration image does anyone know a solution?

hello @djpaulus ,which error ?

Secondly i see from the screen shot it says the current user/pass is admin:test so u can specify a new one ,somthing like admin:Admin123

Hi Cliff this error

During setup I changed pw test in a new pw When I use that pw I get the error

Could you have forgot the admin password that you specified for the openMRS database setup wizard? If so you can drop the database and do a fresh installation.

Hi Juliet, That is not likely :thinking: but I think that a drop of the database is the fastest solution. Thanks for the suggestion

Hi @djpaulus,

Your problem is strange. But please should in case you find a solution, please do well to share it with us so others can use it if they find themselves in a similar situation.

Thanks.

I fixed the problem. I changed the password in the database using this statement: UPDATE openmrs.users SET users.password = “6f0be51d599f59dd1269e12e17949f8ecb9ac963e467ac1400cf0a02eb9f8861ce3cca8f6d34d93c0ca34029497542cbadda20c949affb4cb59269ef4912087b”, users.salt = “c788c6ad82a157b712392ca695dfcf2eed193d7f” where system_id = “admin”; This set the password to Admin123 again. Now I have another problem: The admin hasn’t the right privileges:

does anyone have a solution?

Oh sorry! you may be getting this error because you didn’t unzip the module folder you are trying to install i.e referenceapplication-addons-2.11.0.zip in the modules folder. To solve this unzip and put its contents in the modules folder on your machine.

@djpaulus when you unzip the folder the contents of modules files that end with .omod is the the one you should use.

The admin account not having privileges is a bug in the rest webservices module. If you replace it with the latest snapshot version of the rest webservices module, you will be good to go.

Hi Daniel, Can you tell me where i can find the latest snapshot version and where to place that on the server?

Can you share the contents of your log file via pastebin.com?

Hi Daniel, Thanks for your help! Davy and I are working together.

There are two log files in the .OpenMRS folder: openmrs.log:

and openmrs.1.log

I also see that there’s a folder /webapps/openmrs/WEB_INF which contains folders bundledModules and bundledOwas. Can you tell me which folders OpenMRS is actually using (the ones in .OpenMRS or the ones in /webapps/openmrs/ )?

I mean the tomcat log file.

The tomcat log

Basing on this from the tomcat log:

INFO - Listener.contextInitialized(174) |2021-04-20T09:55:46,258| Using runtime properties file: /data/webapps/tomcat/openmrs-test/.OpenMRS/openmrs-runtime.properties

Your modules folder should be: /data/webapps/tomcat/openmrs-test/modules

Thanks! That folder didn’t exist at all, so Davy created it and copied the omod files there. That worked… thanks! Davy is now working on installing the other modules from the reference implementation.

A couple of hours ago, i released a stable version of the restwebservices module that has this fix. OpenMRS Add Ons

Hello, I am having a similar problem. I used the SDK to setup the platform version. My password and username were not changed. I went to the configuration file to verify.

@dkayiwa

I figured it out. If you use the SDK it doesn’t have @dkayiwa latest version of Rest Web Services so you need to delete the old file and replace it with the updated version. Mine was found in user/kyokobah/openmrs/server/modules.

1 Like