About fixing introductionary issues

I am new to the open MRS community.As my starting point I like to work with introductionary issues.When I work with that issue from where to find the source code related to that issue.

Thanks @nimodi for starting to work on these issues! :slight_smile: Choose a ticket that you would like to start with, and then we shall give you pointers in regards to where to find the source.

Thanks @dkayiwa. I will immediately choose a ticket and inform it to you.

“OpenMRS Standalone STAND-79 Documentation in Open MRS Standalone 1.11 Beta gives wrong password” I would like to working on this issue.How do I start? . I tried to login with my Open MRS id and inform them about my presence for this issue. But I am unable to login. It says “wrong username or password”. I also reset the password and tried to login. It did not work. I also created the help desk for that. But still I do not get the solution.

We have seen your help desk request and responded accordingly! :slight_smile:

Thanks @dkayiwa :slight_smile:

I started to work with “OpenMRS Standalone STAND-79 .Documentation in Open MRS Standalone 1.11 Beta gives wrong password” this issue. I have already installed the open MRS standalone and I have changed the password.What I can do next?:smile:

I have commented on the ticket. :slight_smile:

As a university student, let me know what kind of errors(in introductory issues) should I start with?(if I start a familiar(known) issue it is an encouragement as beginner ) I expect an advice from you.

Feel free to start with any introductory ticket listed on https://wiki.openmrs.org/display/docs/Getting+Started+as+a+Developer

I started work on “OpenMRS CoreTRUNK-5033” issue. When I built the source got the error like following.I tried to fix it by changing environment variables also.But still not fixed.Can you help me to fix it.

Does your environment variable point to a JDK or JRE?

check whether you have properly set the JAVA_HOME. you can verify it by running java -version in a terminal.

It points to jdk

What exact value does it have? What does java -version return? Did you also remember to restart after setting it?

Thank you for helping me.I just fixed it. It was because of not properly setting the JAVA_HOME.

I have already built the code.According to bug I try to fix(TRUNK-5033) there are three classes (OpenmrsConstants, SchedulerConstants and Security) to work on.I want to compile them and see weather I can also get that error and according to given errors try to fix them.How do I compile them?Which are the prerequisites for compile it?

Can you take a look at how to compile from this page? https://wiki.openmrs.org/display/docs/Step+by+Step+Installation+for+Developers You could also just google with this text “how to compile openmrs”

When I configuring netbeans as my IDE, under that need to use maven in netbeans. for that need to checkout open mrs trunk as subversion repository.But http://svn.openmrs.org/openmrs/trunk doesnot exist.Whichone can I give as sub version repository instead of that?

Sorry about the misleading documentation. Let me head there and correct it. We switched from Subversion to Git. Can you take a look at this? https://wiki.openmrs.org/display/docs/Using+Git