WAR File not working

I am trying to install Platform 2.0.2 but it is not working. I am dropping the file into tomcat, it expands and thats it. I cannot initiate setup. I am not sure what am I missing. I tried a war file for 1.11.5 and it works fine.

Anybody experienced the same issue or have suggestions

Which version of Java are you using?

Java Version 1.7.0_80

That is the exact cause of the problem. Platform 2.x requires Java 1.8

OK @dkayiwa … I never got to initiate setup …but I found this page

but there is no "openmrs-runtime.properties "created. I could not find the module folder. It is windows server and I searched the whole machine.

I see … ok I wil try it … Thanks very much @dkayiwa

@dkayiwa if I install Java 1.8 can I run reference app 2.5 module on 1.11.5 ?

Reference Application 2.5 requires platform 2.x If you look in the tomcat log files, you will see the location of the runtime properties file and hence the modules folder.

hello @dkayiwa I installed Java 8 and tomcat 6 , still same problem … this is the logs



I appreciate your help

What shows up in the browser?

Hello @dkayiwa

On left you will find the openmrs files on tomcat … on right you find the browser

By browser i mean web browser like firefox, chrome, or any other :slight_smile:

@dkayiwa I understand :slight_smile: It is the picture on right … the browser says no page found

Can i look at a screenshot of it?

It is attached to my previous reply … I attached one picture it has both a screenshot from the openmrs folder (left)and browser (right)… Thanks again

The OpenMRS Platform running page means the installation was successful.

I agree… however, Openmrs didnt start up and didnt create the properities file.

I tried many previous versions. never seen this before

With platform 2.x, the legacy ui was moved into a module. So to see the login window that i think you are looking for, just download the legacyui module, drop it in the modules folder, and restart tomcat.

Yes @dkayiwa I agree However, I don’t think the war file was extracted fully. I don’t think it created the module folder of the properties file. The logs shows this error.
There is something different about 2.0.1 it is not like previous versions

I’m posting this just in case you haven’t found the solution yet.

Aside from java 1.8 you also need tomcat 8 or later. I know because I have encountered this problem before. The problem was that in tomcat6, 50mb is the upload size limit and the openmrs 2.0 war file is about 71mb. In tomcat 8 or later you have the option to change the limit by changing the following lines in the web.xml file (mine is found in /opt/tomcat/webapps/manager/WEB-INF/web.xml):

Look for:

      <!-- 50MB max -->

Replace it with:

      <!-- 80MB max -->

I’ve also attached a file which discusses in detail the steps I have followed to install OpenMRS 2.0. It might be of some help to you. OpenMRS2.0Installation.pdf (190.8 KB)


1 Like