SSL Error on Mysql While setting up openmrs sdk

The Mysql version should be either 5.6 or 5.7 not 8 basing on the refApp version you are running.

1 Like

i have downgraded to java 8

the serror still stays

What output does the command below yields?

mvn -v

  1. ams@ams:~$ mvn -v

  2. Apache Maven 3.6.3 (cecedd343002696d0abb50b32b541b8a6ba2883f)

  3. Maven home: /opt/maven

  4. Java version: 1.8.0_292, vendor: Private Build, runtime: /usr/lib/jvm/java-8-openjdk-amd64/jre

  5. Default locale: en_US, platform encoding: UTF-8

Sorry for a bother! Which mysql version are you running?

are you able to access your database via terminal? @insookwa

1 Like

So, the warning message you’re seeing about SSL connections is just that, a warning. It doesn’t really indicate why the connection failed. The most likely causes for why it cannot connect are:

  1. MySQL isn’t running
  2. MySQL isn’t running on port 3306
  3. Your MySQL instance isn’t configured to allow the root user to login with a user name and password (this is common on many Linux-distro versions of MySQL)
  4. The user name and password are incorrect

You might be able to get more details by running mvn openmrs-sdk:setup -e.

If the issue is something like 3, you might need to follow the steps discussed here and after that.


yes @herbert24 i am able

trying logging in and drop here the mysql version you are running

Thank you so much @ibacher . This was my problem . after following your advice of checking with

mysql -h localhost -P 3306 --protocol tcp -u root -p i realised root was not being allowed .

Things are now working Thanks @kdaud @jwnasambu @herbert24 for the support


Hello @dev I am have a similar issue, I have realized I can not be able to build a server. irynah@irynah-HP-Spectre-x360-Convertible-13-aw0xxx:~$ mvn openmrs-sdk:setup[I -

I have installed openjdk 8 and mysql 8 and my SDK is running fine.

use mysql -h localhost -P 3306 --protocol tcp -u root -p and see if you are able to connect to the database using root account in case you are not able , follow this solution to fix it

@insookwa i followed that solution and still i get this error

ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: YES)

This is very good @irenyak1 at least we know the problem now.

login to my-sql with sudo privilege.

sudo mysql -u root -p

And then update the root with the one you indicated in setting up the server password using:

ALTER USER 'root'@'localhost' IDENTIFIED WITH mysql_native_password BY 'new-password';

Once this is done stop and start the MySQL server. and ten run the server again

sudo service mysql stop
sudo service mysql start

incase problem persists, kindly share the full logs

Hi @insookwa thank you so much, you had the same idea like this blog. I went ahead and created another user different from root. And from the blog it actually has the same guidance like you have posted. Issue solved. Thanks.

1 Like