SMART Container


(Sanatt Abrol) #21

Did you mean which version of OpenMRS? It should work fine with all 2.0.0+ versions. I have tested the module with 2.2.0 Snapshots and also with stable releases like 2.0.1


(Brian Foxx) #22

Yea that’s what I meant. I’ve tried to use the modules you sent with 2.2 and got all sorts of bean creation errors. I’m reverting to 2.0.1 to see if that works. I think this is an issue of the order in which things were loaded. Do you have a particular strategy that you use to avoid problems like this. Thanks a lot and I want to also thank you for doing the work you all did creating this smart implementation. You all did great work.


(Sanatt Abrol) #23

Thank you :slight_smile: I’d recommend starting with a minimal setup at first (legacy, oauth, fhir and rest module only) and then later on add the modules you need (RefApp etc.)


(Brian Foxx) #24

Yea that’s what I tried but time after time I would end up adding modules after that ended up blowing up the whole thing. When I tried adding the reporting module and its dependencies I ended up not being able to login anymore. I’m trying to figure out how to launch the smart container from a patient context but I can’t seem to be able to pull up that context in the UI. When I try and manually create a patient it won’t let me and gives a cryptic type mismatch error. My ultimate goal is to be able to look up a patient, and click a button that opens up the smart container in a new iframe. This should be possible right?


(Sanatt Abrol) #25

Yeah that’s possible. If you are having trouble logging in, try localhost/openmrs/login endpoint and see if you are able to.


(Sanatt Abrol) #26

No idea why this is happening


(Sanatt Abrol) #27

@bfoxx28 try the updated set of omods here https://github.com/mavrk/oauth2-testbench-modules. There is a way to pass the Patient context to the smart container. See https://github.com/openmrs/openmrs-module-oauth2/blob/4b4bc09ca4e98048ace41685412bb634fed40cc7/omod/src/main/java/org/openmrs/module/oauth2/web/util/CustomTokenEnhancer.java#L30


(Brian Foxx) #28

Thanks a lot. I’ll take a look.