Radiology Module: Manage imaging modalities and procedures

your connection is most likely the problem

You can set up openMRS manually as detailed here::

The devOps makes things easier , but if you dont have the connection/ bandwidth to support it then manual setup is best

@ulrich I am sorry it does not ring a bell.

If you are stuck again at this point you can vagrant ssh cd /vagrant/etc/puppet/environments/master/ puppet apply manifests/site.pp --hiera_config hiera.yaml --modulepath site:modules

puppet continues where it left of, so it should be possible to resume. It can however be that an archive was not downloaded completely and in this case you have to find out which one, where it is and delete it. Because incomplete zip files, tar.gz files cannot be resumed to download.

Give the above commands a try.

And yes you can talk to @kwurst if you’d like. @kwurst do you have a suggestion that might help @ulrich out installing the VM? Unfortunately he is running into timeouts, although we disabled them.

dear @ulrich,

another thing which I just tried is download dcm4chee and jboss manually and make sure they are in

vagrant@pacs:/vagrant$ sudo ls -lh /opt/staging/dcm4chee total 125M -rw-r–r-- 1 root root 30M Mar 7 17:41 -rw-r–r-- 1 root root 95M Mar 7 18:05

puppet then just skips the download and extracts them right away.

Tomcat is downloaded via the package manager apt, not much we can do there.

Hope this helps!!


Thanks for the suggestions, will try them out and revert with the observations.

Hey @teleivo

I am Akash Singhal, a final year dual degree (B.Tech + M.Tech) student from IIT Bombay. I participated in GSoC 2015 with ASCEND, where I developed Chemical Engineering Domain specific modules. Coming from a medical family background and having fascination for technology, I have been highly inclined towards Healthcare Technologies. I had also developed my own SaaS based ‘Lab Management Software’ CerebrumLMS (Demo Credentials:- LabID: wchc, Username: demo, Password: demo123) for my Startup (YourStory Coverage). Here we integrated electronic health records from marketplace to LMS.

This year, I want to work with OpenMRS in GSOC '16. Though most of the listed projects are quite interesting but I like ‘Radiology Module: Manage imaging modalities and procedures’. I watched the video on ‘Radiology Workflow’ and could pretty much relate to the time we developed the whole Lab Information System and eHR integration. Meanwhile, I am following the steps to get started. Please tell me I am not too late to start the discussion for application.


@akigupta131 welcome! no just go ahead setup the dev environment and grab a ticket!

1 Like

Hey @teleivo I am glad to know that. I have been trying on going through your instructions. Till vagrant up works fine and Tomcat also works on port 8080 but then http://localhost:8080/openmrs does not work (throws 404).

I also tried force destroying the vagrant session and reloading it (even with --provision) but then in the terminal it says default: VirtualBox VM is already running.

But now even http://localhost:8080/ does not work. I’m trying more on it but it would be pretty awesome if you could help me with that.


Hey @teleivo. I am facing a bit of an issue with setting up the radiology module. I fixed most of the issues like incomplete downloads and proxy but still tomcat doesn’t seem to be working.:disappointed: I tried downloading tomcat from the apache site and building from source. I also fixed /etc/init.d/tomcat7 start such that it also executes without failure. tomcat runs perfectly inside the VM and also the ''puppet apply manifests/site.pp --hiera_config hiera.yaml --modulepath site:modules" ran without failures but vagrant provision keeps giving tomcat7 errors. (Failure to start tomcat7) How do I fix this issue? UPDATE: All problems have been fixed except one. Vagrant Provision runs without errors. However, OpenMRS is not starting but all the other sites such as localhost:8081/dcm4chee-web3/ and localhost:8081/jmx-console/ are working. When I went to the manager of tomcat and looked at the error as to why OpenMRS hasn’t started, these messages popped up: FAIL - Application at context path /openmrs could not be started FAIL - Encountered exception org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localhost].StandardContext[/openmrs]]

1 Like

A possible fix to the VM already running error: Try running vagrant halt and then vagrant up to restart. (Restarting can also be done by vagrant reload)

Use the vagrant destroy -f command to stop the VM

And restart it using the vagrant up command

Hey thanks @ulrich but following from [quote=“teleivo, post:16, topic:4928”] If vagrant fails just do vagrant destroy -f [/quote]

I already tried that with no success. Also, I had been able to run VM and tomcat (localhost:8080) successfully , just that further localhost:8080/openmrs throws 404.

Ok, so you mean vagrant up command ran without giving you warning messages like dependency faillures ?

default: VirtualBox VM is already running

^ is not an error. I meant to say, even when it says VM is running, tomcat does not seem to be working now (localhost:8080 throws Server sent no data). I can see you are facing the similar problem too.

While vagrant up, I can see huge number of warning with common message Skipping because of failed dependencies but when I reload or try vagrant up again, it just checks for ubuntu/trusty64 and then outputs default: VirtualBox VM is already running as I told earlier. Now even tomcat is not running :confused:


vagrant provision 

Hey @judy Thanks! Had already tried that and tried again now. Still lots of Skipping because of failed dependencies

Did you have warning messages like dependencies faillures ? If yes, how did you come about solving that ?

Manually download the file which is causing it to fail. For example, I had the problem that jboss when unzipping returned error code 9 instead of [0] which was the main cause of all the dependency failures. I realized that the downloaded size of jboss was smaller than the actual file. So I manually downloaded jboss and put them in the /opt/staging/dcm4chee directory. Look at the terminal output and there usually will be one error contributing to all the dependency failures. ssh into vagrant and fix it one by one :slight_smile:


right on! :ice_cream: thats exactly what I meant!

as far as I can see all of you have failed dependencies, because a resource fails to finish downloading an archive due to a timeout (which is due to a bandwidth issue). this incomplete archive, thus cant be unzipped. if you run puppet again it will try to unzip the archive because the file is there but it will simply fail because its incomplete.

please follow my advice, seems to have worked for @venkatp1997 :slight_smile:


Dear students,

we are in the Student Application Period March 14 - 25, 2016

So please dont forget to submit your applications!

Please follow