Problem with logging in to OpenMRS 3.x

Hi, I can’t log in to the OpenMRS 3.x. When I go to this page: and click the ‘Demo Site’ button, using given credentials: u: admin p: Admin123, the login flow becomes a loop - once I insert the username and password, I’m redirected again to the username field. Also, the “Contact administrator” link on OpenMRS does not work. Could you help me with that somehow?

Sorry @beata for this poor experience - we just updated the site and credentials.

Please go to our new demo site at:

Then those credentials will work. I’ll also update you that wiki page right now.

1 Like

Thank you @grace for your help! It works now :slight_smile:

1 Like

You’re most welcome; thanks for the reminder re. the Wiki page! Updated now.

FWIW though, I have to admit that our new demo environment is not quite as feature-current as our previous environment. We’re working to fix that. You can be sure that once that’s fixed I’ll announce this loudly here on Talk :smiley:

(CC @ibacher )

Most likely the server is down at the moment, you may try to check it later

Use username as: admin2

Thanks @kdaud for the feedback. I was wondering if the link provided is working well. The location section doesn’t allow users to confirm their location and proceed. Can you please double check?

Yes @ggomez the experience is the same as yours! This should be a bug. cc: @ibacher @grace

@kdaud , @saskwach and @ggomez have you tried out this link ? OpenMRS

1 Like

Kindly check on where to find work on this link OpenMRS 3.0: A Frontend Framework that enables collaboration and better User Experience - Projects - OpenMRS Wiki. Besides, it will be better to go through the entire documentation to be able to understand what is required to work on this project successfully!