OWA generator improvement

@pascal Hii…I have configured yeoman and npm successfully…after that i installed the generator-openmrs-owa from the npm install command… after selecting the openmrs owa generator it generates (scaffolds) webapp files in AngularJS into my current directory…but after running the command “npm run build:deploy” (for building the scaffolded files), I am getting these errors (below image)…I think it must be error free, then I dont know why I am getting these errors… And if I get myself involved in resolving these errors, then it would fetch a lot of time…Am I doing something wrong ?? It would nice of u if I get a little bit of help !! :slight_smile:

If you are getting an error trying to deploy a freshly scaffolded app, then you’ve most likely found a bug. You should log the bug here: https://issues.openmrs.org/browse/OMRSJS, and include all the details you’ll need to recreate the issue so you can fix it during GSoC :slight_smile:

The error appears to be a parser error. What exactly does your webpack.config.js file look like? Have you tried escaping the backslashes or trying a path without a period in it? I’m not able to test in Windows myself, but it seems like the issue is with that path string.

EDIT: @raff @adamg @tmarzeion have any of you seen this problem on Windows?

@pascal …Resolved !! You were right…the issue was with the local path string…there must not be the backslash at the end of the string. It worked after removing that backslash :slight_smile:

@ankitkumar please create a ticket for this issue. It is not something we want our users to run into, so we want to make sure to remove trailing slashes (at least on Windows).

@pascal …Ticket created !! issue link : https://issues.openmrs.org/browse/OMRSJS-17

@pascal Another bug !! Previously, I have tried deploying the webapp (through yeoman) including jQuery library and it worked fine. But, in case of deploying with the AngularJs library, it gets build successfully, but while selecting the webapp from the owa module, it shows a blank page showing errors in the console window (as below) !! One of my mate @judeniroshan also tried deploying it, and he also got the same error.

Could you suggest what may be the possible reasons for this ?

1 Like

Nice find @ankitkumar. I think the most recent Angular changes were made by @tmarzeion. Maybe he’s seen this error before?

Are you running the version from NPM or the latest master?

@pascal yeah, I m running the version from the npm !! so, i think i should use the version from the latest master, right? :slight_smile:

Well, that means the bug exists in production. My recommendation is to create a ticket for it and implement the fix :sunglasses:

ticket link : https://issues.openmrs.org/browse/OMRSJS-18

@pascal Hii Actually, I got your words wrong, I just pre assumed that its fixed at the master branch without even testing it. Now, I tested it locally by cloning it and found that the issue persists in the master branch too !! I regret for my premature decision of creating an issue without testing it properly !! I just cancelled that issue !!

It’s fine to keep the issue open. The bug still exists, right? :slight_smile:

yeah !! bug still exists !! Ok, so I should reopen the issue and make changes in the summary and description part ! :slight_smile:

Sounds good to me :ok_hand:t3:

@pascal

My Draft Proposal : https://docs.google.com/document/d/1sKOavLbKxV4ocLbjTB5-vvS_xTfF6pcKu9LArit-m-8/edit#heading=h.z6ne0og04bp5

@ankitkumar, I recommend following this thread:

3 Likes

@pascal Ticket link for the 404 error with openmrs-standalone platform :

Great, thanks @ankitkumar. I also created OMRSJS-19 for another bug I found. You’re welcome to fix it, along with OWA-18 if you like.

1 Like

@pascal OMRSJS-19 issue fixed

1 Like

PR link : https://github.com/psbrandt/generator-openmrs-owa/pull/26