OpenMRS showing database connection error

Hello colleagues, Am trying to install the latest openMRS however on running am encountering errors indicated below in the image which I well understand have to do with my database connection however, even after updating {} to my username and password of mysql the errors are still popping up. just wondering where am getting it wrong. Any help rendered is highly welcome. Thanks in advance

Sorry about it. Kindly use paste bin to share your error log the screen you have shared, words are not clear.

1 Like

@lgilbert use pastebin, so that we can get your full server los and critically follow this

1 Like

hello @lgilbert, can you specify which package are you exactly trying to run , that is

  • Standalone
  • SDK
  • Manually deploying the war file in already existing TomCat

Have you also had a look at this and this?

1 Like

U should also try to ensure that the database actually exists otherwise the connection will be failing too…check this out Unable to find a runtime properties file

1 Like

@jwnasambu and @gcliff here are the errors via pastebin

I actually cloned from the master branch and performed the compilations as directed from github.

@reagan this could be of great help however am not running the openmrs sdk, so am finding it hard to locate the properties file such that i can change the user name and password.

@lgilbert how about this

1 Like

Maybe to be more clear! Is this where am supposed to make the database changes such that they be inline with mySQL on my pc?

I suppose the error is due to login credentials. What is the password to your Username: root?


1 Like

1 Like

great thanks to all the support rendered it is really of great help. Am now a step closer, I have managed to pass the database error by deleting all the older openmrs files I had in my different directories hence passing that task.

Now am stack on a very familiar page " If you are seeing this page, it means that the OpenMRS Platform is running successfully, but no user interface module is installed. Learn about the available User Interface Modules

If you are a developer, you can access the REST API. (See REST documentation for clients)" indicating that.

I well understand that this requires some .omon files to be installed in my “C:\Users\LuckyGilbert\AppData\Roaming\OpenMRS\modules” folder and in particular legacy UI. I have downloaded the latest legacyUI from OpenMRS Add Ons however the same problem is still popping up. I believe am missing out on something small but am failing to locate it.

your help is once again welcome. Thanks

I have been trying to look through different solutions and one of them was to clone and build my own legacy ui module from, however according to what i have read it’s like this module is being retired, so am inquiring on a better option in case any. thank you

Thats great @lgilbert.

But regarding the directory where to install the legacy UI , you got it wrong.

under the webapps folder in your Tomcat folder, Another directory is created at runtime as below \openmrs\WEB-INF\bundledModules, Thats where you should deploy the legacyUi omod file/ you dont need to clone and build your own , just get one from the addons repo

1 Like

@mozzy thanks for this correction. I have actually visited this \openmrs\WEB-INF\bundledModules this folder in my tomcat and came to realize that i don’t have any openmrs folder or war file in it even when I try to perform a mvn clean install. I have then tried performing a mvn jetty:run and the build failed causing errors. please look through and advise on what could be the problem

1 Like

can you first try to explain briefly the steps you took to deploy the war file up to the stage getting the above screen?

1- I performed a mvn clean install -Dmaven.test.skip=true which was a success 2- Edited the configuration and used tomcat 9, and set the command line to jetty:run 3- Then I ran the project from the run tab thus triggering tomcat automatically 4 - put in http://localhost:8080/openmrs/ 5- configured in mySQL password and name thus reaching that point

1 Like

Didint you manually deploy the built openmrs-core war file into tomacat’s webbapps folder?