Openmrs Core throws an Exception During Installation

can u paste your error log here https://pastebin.com.

@kdaud have you confirmed that your mysql is up and running?

@lgilbert tomcat starts successfully on command line as well. Mysql is up and running. Am failing to find out the cause of the issue. I shared the log error in the snapshots as shown in the above threads

@kdaud when you check your available databases don’t you see any database in the names of “openmrs” created?

Well the one that now exists is the one that I created in Mysql as suggested in your first response

well you can follow this OpenMRS showing database connection error it will help you.

I took time to read through the threads provided by @lgilbert, @reagan, @herbert24, @mozzy! I decided to re-run Mysql and OpenMRS - Enterprise version But the same error occurs. Could their be a file that needs to be edited? Or. Actually am installing Openmrs Enterprise installation NOT standalone installation. cc: @ruhanga, @irenyak1

Are you trying to use the generated war file from your IDE or downloaded version? if thats the case, I would suggest you re-run the project afresh. By this I mean deleting all the generated openmrs files in the following directories. C:\Users[user-name].m2\repository\org and C:\Users\user-name\AppData\Roaming. there after start again from scratch

1 Like

@kdaud , to get a little step backward , what is the use case for you to deploy the war file in tomcat ?? i would suggest you install openmrs standalone , its quick way to start up

Its the downloaded version

@mozzy I deployed it to generated openmrs enterprise during the installation process.

As per the advise given by @mozzy, have installed standalone successfully with ease. But I feel I didn’t figure out the issue though standalone has worked out. And am so enthusiastic to discovering things and I fear to give up that is why again and again tried to re-install but I didn’t succeed. But standalone is working well. Thanks to all devs for helping me through.

1 Like

Woow i like that @kdaud . Ok lets go back to the previous issues :smiley: . where had we stopped ?? can you briefly describe the steps you took to come to the point your stuck ??

@mozzy I downloaded openmrs.war file ( Platform 2.2.0 WAR (for Enterprise)). Started tomcat, went in Manage Apps and deployed the war file into tomcat server. Clicked in /opemrs file that was deployed to install the software but the process didn’t complete at the last step when it threw an exception i shared in the log

@kdaud, do you mind restarting that process afresh and we move together on each step you take?

@kdaudi,j had the same similar issue, but later with brother@mozzy helped me to fix it, j would advise, to use the version of jdk 8 and make sure its classpath is set correctly, Apache tomcat server is a must to be configured and mysql for database but for standalone application, it comes with its configured database server but ofcourse that doesnt mean you dont need mysql server,after downloading standardalone version specifically 2.9.0, if you have downloaded it already, extract the zip file it again , use the newly folder and run it j hope everying will run correctly.

1 Like

Thanks @sharif, for your response. I actually succeeded in installing Standalone application after failing to install Openmrs enterprise version.

1 Like

@lgilbert, it will be awosome if i go through that challenge, I actually preferred enterprise edition and also figure out the issue

1 Like

@kdaud have you set a password for root account in mysql ??

@mozzy, Yah, the password is set. And I have two accounts: root and user account each with different password

1 Like