.omod Generated Crashing Standalone

Probably or I installed some unwanted stuff in my eclipse when working on it.

Since it was only for two files and the PR was merged, do you mind pulling the changes and generate a .omod on your end?

@gayanw do you think those are small and simple enough to be good GCI coding tasks?

Yes, I think they are simple enough as there is no much logic to it. Understanding Swagger model classes will be good enough.

@gayanw do you think you can create those GCI tasks? :slight_smile:

Okay will do. I didn’t know about the GCI up until now.

BTW may I apply as a GCI mentor too? :smile:

An answer to your question can be found here: Google Code-In Application Updates

Just did with your changes included. But I didn’t see any error.

May be you should try creating a new distribution server and deploying the webservices module there.

1 Like

Which error are you talking about?

No, it was just a reply to niccie post.

After command “mvn clean install -DskipTests” maven is not generating omod file in target folder for openmrs.module

@narukumar share the error logs

mvn clean install -DskipTests ideally skips the tests by default however it also builds the files but mvn clean install will build without skipping tests , does it build your project successfully without issues at first

It doesn’t gives any error, it build the jar but not omod.

yes, it build the project successfully but it doesn’t generate omod

@narukumar are you running the mvn clean install command from the root folder ?

Which project are you building ?

Yes, I was working on another machine earlier, on that openmrs module is working fine. When I did clone the code to another machine and build the project, it just do not generate omod

I have created openmrs module for openmrs enterprise from maven archtype.

is it possible to look at the module you have created, do you mind sharing the screen shot of the target folder of your module

Yes, sure. This is the screenshot of target folder