.omod Generated Crashing Standalone

@gayanw she was using the snapshot version of the rest webservices module.

I mean the swagger errors showing up in the picture can’t be relevant :slight_smile: The crash has to be due to something else.

I just tried running 2.22.0-SNAPSHOT version of webservices.rest module on reference application 2.7.0-SNAPSHOT. And there was no errors.

I didn’t try the standalone version. May be there are other ways to reproduce.

@gayanw ignore the word crash. I think she simply did mean the above screenshot. What would you suggest as the way forward to resolve these errors? https://qa-refapp.openmrs.org/openmrs/module/webservices/rest/apiDocs.htm

@gayanw @dkayiwa

Sorry for the late reply.

@gayanw I granted you access to the .omod.

As Daniel has replied in above, we can first look into those errors.

I also downloaded and tried with the latest Rest .omod file and it works just fine with no errors. Therefore errors seems to be with .omod snapshot.

Yes. I too tried your omod and I could reproduce the same error. May be it is to do with the changes you made to that omod.


@dkayiwa, In the Swagger UI upgrade we enabled spec validation. So a quick hack is to disable it. But I think the ideal solution will be to document these undocumented resources. I have already wrote a Wiki page on this.


There are already issues open for these:

These actually are tasks and not bugs. I’m thinking of opening tasks for each resource. So these swagger validation errors will disappear.

Probably or I installed some unwanted stuff in my eclipse when working on it.

Since it was only for two files and the PR was merged, do you mind pulling the changes and generate a .omod on your end?

@gayanw do you think those are small and simple enough to be good GCI coding tasks?

Yes, I think they are simple enough as there is no much logic to it. Understanding Swagger model classes will be good enough.

@gayanw do you think you can create those GCI tasks? :slight_smile:

Okay will do. I didn’t know about the GCI up until now.

BTW may I apply as a GCI mentor too? :smile:

An answer to your question can be found here: Google Code-In Application Updates

Just did with your changes included. But I didn’t see any error.

May be you should try creating a new distribution server and deploying the webservices module there.

1 Like

Which error are you talking about?

No, it was just a reply to niccie post.

After command “mvn clean install -DskipTests” maven is not generating omod file in target folder for openmrs.module

@narukumar share the error logs

mvn clean install -DskipTests ideally skips the tests by default however it also builds the files but mvn clean install will build without skipping tests , does it build your project successfully without issues at first

It doesn’t gives any error, it build the jar but not omod.

yes, it build the project successfully but it doesn’t generate omod

@narukumar are you running the mvn clean install command from the root folder ?