Is it possible to release 2.3.x modules?

Ok. I’ll use those modules

Unfortunately I am still not able to successfully start openmrs with the listed modules. Getting the same error as above. Did you compile the appframework module yourself or did you download from the modules site?

I pulled a fresh copy of coreapps 1.7.x, compiled and it doesn’t work

I fetch all modules from the Maven Nexus repo using the SDK… except Core Apps 1.7.1-SNAPSHOT of course that needs to be built.

Can you pastebin somewhere the results of your build of the 1.7.x branch? (I’m trying it again from a fresh .m2 in the meantime.)

I upgraded appframework from 2.5 to 2.6 and it now works!

Are you good to go then?

Yup. Thanks

How long does it take you for a Pull Request to get merged in? I’m a little unsure of the process. I have one that’s been open for quite a while and I can see you’ve been able to get a couple merged in already.


Very fast in general (~1 day), but I guess that it depends on the reviewer. You should probably ping @wyclif about it on the actual PR thread on GitHub.

@insiderish pull request for which ticket?

@insiderish the reason is simply because the ticket status says “IN DEVELOPMENT”. To indicate that you are done with development and hence ready for review/merge, you would need to hit the “Request Code Review” button. This being a reference application ticket, it would instead require you to hit the “Ready for Testing” button to indicate that you are ready for review. But this is not your fault. It is ours because the reference application tickets workflow is confusing!!! I have never liked it myself. :confused:

Ah, thanks. I’ll do that now.