I can't configure OpenMRS enterprise even with windows 7..help please?

I had a problem configuring OpenMRS enterprise with windows 10

So I switched to windows 7 and tried again and the same problem happened again. I tried what @arbaughj kindly mentioned in this post:

and still it’s not working.

Please provide a screen shot or copy output from the command line that indicates your database is running on the local server where you’ve installed OpenMRS Platform.

how do I get the command line?

this is a screenshot of Workbench with the database running on the localhost

1 Like

This is a list of the apps and procedured aloowed through the firewall. and MySQL is one of them.

My implementation is stuck at this point. Everything is ready in the standalone version. One more obstacle to overcome (:

any suggestions are very welcomed even if it sounds too simple or like a no-brainer. Just throw it at me :smile:


I’m sorry to hear you’re still having problems.

1.) Can you run the following SQL from your MySQL workbench… SHOW DATABASES; If you get an error, you’re account doesn’t have appropriate permissions. 2.) Can you try disabling the firewall completely temporarily? 3.) Can you find and delete the runtime properties file (if it exists), this will force the wizard to try to create one from scratch. For a hint on where that file is, see here… https://wiki.openmrs.org/display/docs/Overriding+OpenMRS+Default+Runtime+Properties 4.) In the wizard, are you telling it to create a new user and new database? Perhaps if the above doesn’t get you going, you could include some screenshots of what you’re putting in each screen of the wizard.

I hope you can get over this (last) hurdle.

Are you familiar with Linux? I always run my OpenMRS severs on Linux. If you’re not familiar with Linux, now is probably not the time to start, especially since you’re so close with your Windows installation. Here are some recent instructions for getting started with Ubuntu 14.04.

Here is what we want on the server… • Java 7 - http://www.2daygeek.com/how-to-install-java-7-openjdk-on-ubuntu/ • Tomcat 7 - https://help.ubuntu.com/lts/serverguide/tomcat.html • MySQL 5.6 - http://www.tocker.ca/2014/04/21/installing-mysql-5-6-on-ubuntu-14-04-trusty-tahr.html • OpenMRS Platform 1.11.4 - https://wiki.openmrs.org/display/RES/Platform+Release+Notes • OpenMRS Reference Application 2.3 - https://wiki.openmrs.org/display/RES/Release+notes+2.3


ok so here are screenshots of the whole process:

That’s the log from the error page…back to the runtime.properties thing. I’m using MySQL Apache Tomcat 6.0.29 JDK 7 and OpenMRS platform 1.11.4

One curious thing though, @arbaughj You told me that OpenMRS doesn’t use jdbc to connect to MySQL and yet it says in the “database connection” part that it’s using it. Is that what’s wrong?

Is there any way I can creat the runtime.Properties file and put it in the mentioned directory?

Hi @hossam, Thanks for documenting the steps of what you’re doing. Did you change the Database connection URL, seen in step 1 of 5?

Mine is… jdbc:mysql://localhost:3306/openmrs?autoReconnect=true&sessionVariables=storage_engine=InnoDB&useUnicode=true&characterEncoding=UTF-8

I wonder if it’s not picking up the @DBNAME@ variable, maybe that’s just the way it’s displayed.

It seems it’s having trouble to actually create the database, so I suspect that the connection URL isn’t the problem.

Can you try manually creating the database with your MySQL utility? To do that, run this command. CREATE DATABASE openmrs DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci;

If that works, you could specify that the database is already created when you run the wizard again and go from there.

Let me ask the obvious: Are you sure you’re using the right MySQL username/password in the configuration wizard?

I hope you can get this straightened out before too long.


yes,I’m sure about the user name and password and I did the show databases command and it worked fine

I will try to create the database and let you know what happens. Thank you!

I too faced the same issue, I tried using mysql 5.5 then it worked fine

1 Like

it worked!

Not only did it work…It kept working too!! :smiley: :smiley:

I couldn’t believe my eyes…literally!..I was like seriously? u r actually working?! I’m so happy :smiley: I started downloading MySQL 5.5 and in the meanwhile i tried MySQL which I already had downloaded and I was waiting for the dreaded orange error I go so used to and bam…it works.

Thank you @fowler45 so much! @arbaughj I can’t thank you enough.