Getting 404 Error While Trying to GET data from API using RESTClient

My suggestion is to read the documentation from the original source (pages from openmrs.org). Never heard about this gitbook pages, they can be outdated and at a first glance they’re not so good.

@darius Do I need to install REST web service module in the same folder where I installed openmrs-core.

And from where I will call GET and POST. Is it from openmrs-core or REST web service module.

Sorry to disturb you lot as I am new and confused about openmrs.

Put it in the modules folder which is in the application data folder. https://wiki.openmrs.org/display/docs/Overriding+OpenMRS+Default+Runtime+Properties If you looked at your logs, you will see the folder of the runtime properties folder that is being used.

@dkayiwa @darius
I cloned openmrs-core. I cloned REST web service module in the modules folder under openmrs-core. Ran command “mvn clean install” and Everything showed “Success”. Ran command “jetty:run” and jetty server ran properly. Still I can only access following link : http://localhost:8080/openmrs/

Except above URL I am unable to access any REST API and unable to GET or POST as well.

I am uploading some screen shot.

Server Error: DispatcherServlet.noHandlerFound(1120) |2017-02-15 14:48:28,283| No mapping found for HTTP request with URI [/openmrs/ws/rest/v1/resource] in DispatcherServlet with name ‘openmrs’

What Should I do please let me know. Is there any video tutorial. If yes please share some link with me.

If you paste your logs at pastebin.com, i will show you the modules folder where you are supposed to paste the .omod

@abusufian92, it sounds like you’re trying to develop a client that talks to the OpenMRS REST API. In this case, there is no reason to build OpenMRS from source.

I strongly recommend that you take either one of these easier paths:

(a) go to http://openmrs.org/download/ and get the latest Standalone of the OpenMRS Platform (b) use http://om.rs/sdk and (1) use the setup command to set up a Platform Server and (2) use the deploy command to deploy the webservices.rest module to this server


If you insist on trying to build from source…

The second step here is wrong. openmrs-core and the webservices.rest module are different projects that need to be built independently. Building the module produces an “omod” file (which you can just download from http://modules.openmrs.org instead of building it from source) and you need to put this in the modules folder for the running application (see Daniel’s link to find the right place), not in the source of openmrs-core.

1 Like

@dkayiwa

Please Click Following link…Where I added full log…May be in this screen you won’t be able to see full log.You need to click URL to see full log. Thanks in advance. Please Help me.

http://pastebin.com/FjUswxyT

I mean the full log that happens from the time you start to run openmrs.

@dkayiwa

Please visit following link. Thanks in advance.

http://pastebin.com/jtwDFJgU

Besides pasting the OMOD, you need to start the module.

From this section of your log: INFO - Listener.contextInitialized(174) |2017-02-20 13:18:15,977| Using runtime properties file: C:\Users\Tanzir\Application Data\OpenMRS\openmrs-runtime.properties

Do you have the rest webservices omod in? C:\Users\Tanzir\Application Data\OpenMRS\modules

@dkayiwa

I found the modules folder in the following directory-

C:\Users\Tanzir\AppData\Roaming\OpenMRS\modules

Though the folder is empty.

Do I need to clone full REST webservice omod from following link in the modules folder-

Or I just need to download Logic omod from following link and keep it in the modules folder:

Download the webservices rest module from this link https://modules.openmrs.org/#/show/153/webservices-rest and paste it in that folder and restart openmrs.

@dkayiwa

Thanks for helping me.I followed your instruction and it worked properly. Now I can POST and GET data properly using Firefox RestClient Debugger.

I have some more question’s regarding this.

  1. I am unable to find any @RequestMapping from where POST can work.

  2. If I want to edit some info from existing module say for : if I want to edit some info from Person Add or Patient Registration the where I need to edit those info because I am unable to find any Controller.

  3. If I want to edit any field or want to add any field in the existing module then openmrs-core is the main or I need to add anythings else from openmrs git.

In particular : I want to reach the controller point where POST,GET,DELETE,PUT this kind of @RequestMapping has been done though I am unable to find. Configuration had been done using Bean and in the API folder I found Interface but I am unable to find that “where REST api request from client is manipulated”.

Thanks in advance.

Did you get a chance to read this and its child pages? https://wiki.openmrs.org/display/docs/REST+Module

Hi, I am Installed bahmni in vagarntbox . I am getting 404 thrown: page/object not found

and Postman getting same Error.

POST /ws/rest/v1/person/uuidofperson/name

Body content: {“givenName”: “John”, “familyName”: “Smith”}

this is my vgarant server log https://hastebin.com/adukapemiq.sql

Hi , Could u please assist, I downloaded the legacyui module and pasted that file in appdata\roaming\openmrs\modules and restarted Tomcat server. But still receive 404 error. Please assist /advise

Can you share the contents of your server side log via pastebin.com?

Yes, I saw now…Let me share the requested details.when u tell server side log… can u please specifie where I can fetch it?

Hi Please find the log pasted : https://pastebin.com/GwtjwTKp