Failing setup dev setup using yarn

Hello forks, I am trying to set up dev setup for O3 on my machine using

yarn setup

But my machine freezes and fails to complete setup. Has this happened to anyone before and it seems I can not proceed from there. @dkayiwa

Oh sorry @suubi7 Kindly do you mind sharing the error you are getting after running the command?

1 Like

It does not actually give an error log, it just hangs and does not complete. @jwnasambu

@openmrs/esm-devtools-app:build: @openmrs/esm-devtools-app:build: WARNING in asset size limit: The following asset(s) exceed the recommended size limit (244 KiB). @openmrs/esm-devtools-app:build: This can impact web performance. @openmrs/esm-devtools-app:build: Assets: @openmrs/esm-devtools-app:build: 889.js (402 KiB) @openmrs/esm-devtools-app:build: @openmrs/esm-devtools-app:build: webpack 5.88.0 compiled with 1 warning in 152624 ms

it stops here

Oh sorry! I can relate coz I have ever been there.

1 Like

What did you do to go around it @jwnasambu

You are right! this warning is just informing us that the size of the 889.js asset in your application exceeds the recommended limit, which could affect the performance of your web application. You may want to consider optimizing the size of this asset or investigating ways to improve the overall performance of your application during the build process. @dennis, @ibacher , @vasharma05 kindly is it advisable to use TerserPlugin to minify and compress the code to help unblock @suubi7?


cc: @dennis This seems related to the issue you were experiencing…

We already use Terser; it’s built into Webpack 5.

@suubi7 Running yarn setup isn’t actually critical, as long as it gets past the yarn install step. It would probably be useful to also run yarn turbo build --filter=@openmrs/esm-framework, but you should actually be good to go.


@ibacher @jwnasambu I am running into this error when I try to run O3 locally using

yarn run: omrs

Error is Error: ENOENT: no such file or directory, stat '/home/suubi7/OpenMRS-Tickets/O3-1409/openmrs-esm-core/packages/shell/esm-app-shell/dist/index.html'

Could this be because of failing yarn setup or yarn build

I am trying to view my changes.

Hmmm… Yes, it does appear you need to build the app shell.

@ibacher this happens when building the project through yarn build or can yarn run:shell work as well?

Not without the build step. Unfortunately, with the information you’ve supplied in this thread, I really have no idea why anything is failing…

@ibacher When I run yarn build this earlier problem comes again. The process does not complete. Not sure why as well

Are you able to provide the full output?

Sure @ibacher before the terminal crushes this is the log

Ok… So I’m seeing a few things here:

  1. There are some cached files (@openmrs/webpack-config:build: cache hit, replaying output 54b0845024a06984)
  2. Build performance seems to be drastically decreasing as the build goes on (the framework build takes 51989ms whereas the devtools, which is lighter-weight takes 152624ms) (this may help me with another issue: what’s the output of git rev-parse HEAD?)

Could you please try running yarn turbo build --concurrency 1 and see if that helps? You may need to run it several times (the idea here is to build up the Turbo cache).


The output for git rev-parse HEAD gives


@ibacher The turbo build is successful but when i run yarn run:omrs the SPA gives a blank page nothing is shown.

What’s the full command you’re running?

This is the command I am running to run SPA

yarn build  or yarn setup 

need to pass to ensure all necessary configs, files and dependencies are setup well. I guess after they pass yarn run:shell should spin up yo dev environment.