Failed to decrypt a password for server bintraty -sdk while creating openmrs module

Hi all any help j tried to create a module following the procedures given, all process was ok but j got an error after running my module from with in eclipse ide. the link to the error j got is found in pastebin here

Do u have the security settings xml file in ur .m2 file?

1 Like

j tried to set it up but again am getting the same error

@sharif i would recommend that you have a look at this

1 Like

@gcliff thanks

1 Like

your welcome boss

cc @mozzy, any advice on this issue [ ]

I havent got exactly where the error arose from. Can you describe the steps and commands you used up to the point of the error ??

Well , i was creating my first module, Firstly, j used this command to setup the sdk ->mvn org.openmrs.maven.plugins:openmrs-sdk-maven-plugin:setup-sdk. all the setup was fine in the first case. Secondly, j continued to create a server, j used openmrs distribution platform because it includes to be having installed mysql 5.6 + which j have installed. Following all the procedures brought an error showing password for the server sdk failed to decrypt. the same problem might have caused the problem in creating a module because in this case if the server fail to be created, j dont think there is away to continue to create a successfull module without errors. j think am a bit clear

No ,you’re not clear , still i dont get the exact point where you get the error. can you use bullets , to clearly describe the steps , and where exactly that error arises ??

i tried to follow this link, but when j reached on step where there is Basic usage where there is creation of the server, this error occurred.[ ].

Are you using the maven plugin for eclipse to do this ?? like are you doing this from eclipse ??

No i downloaded maven 3.5.2 from online and added them to the classpath even when j call mvn -v from the command prompt, it shows the exact version of maven.

C:\Users\SHARIF> java -version java version “1.8.0_211” Java™ SE Runtime Environment (build 1.8.0_211-b12) Java HotSpot™ 64-Bit Server VM (build 25.211-b12, mixed mode)

C:\Users\SHARIF>mvn -v Apache Maven 3.5.2 (138edd61fd100ec658bfa2d307c43b76940a5d7d; 2017-10-17T23:58:13-08:00) Maven home: c:\Program Files\Apache Software Foundation\apache-maven-3.5.2-bin\apache-maven-3.5.2\bin… Java version: 1.8.0_211, vendor: Oracle Corporation Java home: C:\Program Files\Java\jre1.8.0_211 Default locale: en_US, platform encoding: Cp1252 OS name: “windows 10”, version: “10.0”, arch: “amd64”, family: “windows” ‘cmd’ is not recognized as an internal or external command, operable program or batch file.

@mozzy thanks for helping me out and thanks for that time , though the issue is still on the table, Actually there is a related topic chat so you can also peruse through Maven errors when compiling on Windows.

@sharif, let me have a look at your maven settings file in the .m2 folder

C:\Users\SHARIF.m2\repository. its where all maven repositories are stored,In m2 folder there is no settings.xml

@mozzy this is my settings.xml but its location is not found in m2.folder, its found in maven repository. so what do j need to do after

<?xml version="1.0" encoding="UTF-8"?>
<!-- Another sample, using keys to authenticate.
  <passphrase>optional; leave empty if not used.</passphrase>

dont you have a seetings.xml file in this directory C:\Users\user_name\.m2 ??

what is the actual directory for your settings file ??

yes j dont hava settings.xml file in that directory. so should j include them into that directory