Errors setting up PACS Integration module

I was watching the videos and really helped me a lot. I learned how to install a server (CentOS 6.7) with Bahmni projects. I learned how to install the dcm4chee project from the repository Bahmni. I did tests and I could see that dcm4chee working properly.

Then in the section Setup PACS Integration module there is not much information on how to integrate these two projects (Bahmni MRS and DCM4CHEE). Analyzing the installation guide and I concluded that these commands would be sufficient.

  • yum install -y dcm4chee pacs-integration

  • I do some tests and found that there is no conflict, if you use ports other than 8080 and 8083. For my case, I’m using DCM4CHEE ports in 8088 and 8089, and now works perfect.

According to the installation guide, you should have access to this URL: http://ipaddress:8080/pacs-integration, but when I try to enter the URL, I have no answer. I checked the PostgreSQL database, can not find the tables Modality, Order Type and Markers.

Then what additional configuration I make can enter the url mentioned?


Can you try http://ipaddress:8084/pacs-integration and see what that shows up. The yum rpm installation starts that service on port 8084 as default.

The tables, however, should have been present if it got installed correctly. Were you checking the bahmni_pacs database?

Hi Arjun,

I’m sorry for not answer quickly. I was testing the installation process of pacs-integration. I could see that after installing pacs-integration, bahmni_pacs data base is created, but it does not contain tables. Can you help me to create these tables? I mean, do you have a script to create the tables (Modality, Order_Type and Markers)?

I had another observation, the bahmni-pacs service does not start. I start the service manually with the command:

  • sudo service bahmni-pacs start

The terminal shows: Starting bahmni-pacs

But, if I run the command:

  • sudo service bahmni-pacs status

The terminal shows: Service bahmni-pacs is not running

Is there a log file, to see if there is an error during the service start?.

I hope you can help me. I will be grateful with you.


Hi Frank, The logs should be in /var/log/bahmni-pacs/bahmni-pacs.log. Can you check whats there in it?

Hello @frodriguezm17. Were you able to setup and get dcm4che to work? This discussion will help others in future if they want to setup dcm4che.

Hello @gsluthra ,

Sorry for not responding quickly.

After testing With pacs/dcm4chee, I found that this works perfectly but independently. I have not tested with bamhni, pacs-integration and pacs. I will review the log generated by the pacs-integration and I will share this.


Hello. I am also in the midst of setting up the PACS using dcm4chee on bahmni.

I have installed the pacs-integration and dcm4chee packages.

The url http://ipaddress:8084/pacs-integration shows that pacs-integration is running.

I have not attempted the data setup section in the postgres database. Working on that now.

Opening ip:8001/dcm4chee-web3 and ip:8001/oviyam2 gives issues.

ip:8001/dcm4chee-web3 shows: Internal error Throwable: ITab.getPanel() returned null. TabbedPanel [0:modules] ITab index [0] Page: class org.apache.wicket.Page

Choosing ‘Desktop’ or ‘Reading room’ on the page gives: Internal error Throwable: Attempt to set model object on null model of component: modules:cssSelect Page: class org.apache.wicket.Page

and ip:8001/oviyam2 gives me 404.

Quick question: Wouldn’t dcm4chee and oviyam still work independently without data setup for the pacs integration?

And also: small assistance with the data setup on would be helpful. I am unclear as to where those screenshots come from. Postgresql?

-Daniel Ng-

Hi Daniel Ng, The errors you are seeing are probably because dcm4chee (JBoss) hasn’t started up properly. I was recently seeing this error wherein another service that dcm4chee was trying to start up wasn’t starting up due to a port conflict in the new Ansible setup that we are trying Can you check in the logs to find the cause? You would find the logs here : /var/lib/bahmni/dcm4chee-2.18.1-psql/server/default/log/server.log

Once started properly, both dcm4chee and oviyam2 would work independently without data setup of pacs-integration.

Yes. the screenshots are from postgresql. Those are the tables where you have to add rows to

  1. Map the modality/PACS to which pacs-integration would send ORM message
  2. Map the order type to modality
  3. set the markers table for the atom feed reader to pick up latest entries.

Hello @arjun, sorry for the late reply.

The log file is pretty long, about 2600 lines, would you like me to pastebin the whole thing?

Running: cat /var/lib/bahmni/dcm4chee-2.18.1-psql/server/default/log/server.log | grep -e “ERROR” gives me the following:

Lastly, the screenshots from postgresql look like the interface is graphical. You are manipulating the databases from dcm4chee?

-Daniel Ng-

You might have to look a little up in the logs. For me doing the vi shows up this as a first line when the issue exists 2016-04-04 14:44:04,424 WARN -> (main) [org.jboss.system.ServiceController] Problem starting service jboss:service=WebService java.lang.Exception: Port 8083 already in use. I am not sure if its the same issue for you. But you can check for it to confirm.

If the issue is about port conflict, you can alternatively confirm what port dcm4chee is trying to start in this file /var/lib/bahmni/dcm4chee-2.18.1-psql/server/default/conf/jboss-service.xml and iptables or netstat will tell you anything else is running on that port

When i faced the issue i noticed both dcm4chee webservice and bahmni-reports were configured to run on 8083. The workaround that i am applying for now, till the time the team fixes it properly, is to stop the bahmni-reports service and then restart dcm4chee. But i am trying out the latest Ansible that is not yet completely QAed and released.

The screenshots are from IntelliJ with darcula theme :slight_smile:

Yes, I do have the same issue: 2016-04-03 17:21:01,918 WARN -> (main) [org.jboss.system.ServiceController] Problem starting service jboss:service=WebServicejava.lang.Exception: Port 8083 already in use.

Regarding the xml file, there are these lines of code that seem to denote port 8083’s use:

Unfortunately, iptables -L doesn’t show me any rules. I am running on Google’s Cloud Platform so I’m not sure if that has a role.

Noted about the workaround, maybe I will try it later. Hope it’ll be solved soon!

And thanks for the info lastly!

-Daniel Ng-

Hi @arjun ,

I have been trying to setup bahmni-pacs without success.

When i start the service manually with the command:

sudo service bahmni-pacs start The terminal shows: Starting bahmni-pacs

But, if I run the command:

sudo service bahmni-pacs status The terminal shows: Service bahmni-pacs is not running

After checking my bahmni-pacs.log, i found this.

org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'entityManagerFactory' defined in class path resource [org/springframework/boot/autoconfigure/orm/jpa/HibernateJpaAutoConfiguration.class]: Invocation of init method failed; nested exception is java.lang.NoSuchMethodError: javax.persistence.spi.PersistenceUnitInfo.getValidationMode()Ljavax/persistence/ValidationMode;
    at org.springframework.boot.context.embedded.EmbeddedWebApplicationContext.refresh(
    at org.springframework.boot.SpringApplication.refresh(
    at org.springframework.boot.context.web.SpringBootServletInitializer.createRootApplicationContext(
    at org.springframework.boot.context.web.SpringBootServletInitializer.onStartup(
    at org.springframework.web.SpringServletContainerInitializer.onStartup(
    at org.apache.catalina.core.StandardContext.startInternal(
    at org.apache.catalina.util.LifecycleBase.start(
    at org.apache.catalina.core.ContainerBase$
    at org.apache.catalina.core.ContainerBase$
    at Source)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor$ Source)
    at Source)

Caused by: java.lang.NoSuchMethodError: javax.persistence.spi.PersistenceUnitInfo.getValidationMode()Ljavax/persistence/ValidationMode;
    at org.hibernate.jpa.boot.internal.PersistenceUnitInfoDescriptor.getValidationMode(
    at org.hibernate.jpa.boot.internal.EntityManagerFactoryBuilderImpl.mergePropertySources(
    at org.hibernate.jpa.boot.internal.EntityManagerFactoryBuilderImpl.<init>(
    at org.hibernate.jpa.boot.internal.EntityManagerFactoryBuilderImpl.<init>(
    at org.springframework.orm.jpa.vendor.SpringHibernateJpaPersistenceProvider$1.<init>(
    at org.springframework.orm.jpa.vendor.SpringHibernateJpaPersistenceProvider.createContainerEntityManagerFactory(
    at org.springframework.orm.jpa.LocalContainerEntityManagerFactoryBean.createNativeEntityManagerFactory(
    at org.springframework.orm.jpa.AbstractEntityManagerFactoryBean.afterPropertiesSet(
    ... 24 common frames omitted

I have been stuck with this for days. Can you please help.


1 Like

Hi @shobhab, Not sure why should you get this error. Are these the full error logs? Also, can you describe a little more as to how you went about installing this and what is the version of bahmni-pacs installed?

Actually we are very close to doing 0.81 release, in which bahmni-pacs has been renamed to pacs-integration and setup made a bit easier. If you can wait for about a week and then take the new release, it would be bit easier to support.

Hi @arjun, I followed the instruction mentioned in

Do i need to consider anything else?

Hi @shobhab, Were you able to get this working? Or are you still stuck?

I have tried to explain this end to end in a blog post here

See if it helps.

Hi everyone,

@shobhab I have the same problem, the file pacs-integration.log show’s this. pacs-integration.txt (32.1 KB) Do you could solve this problem? Someone knows, why have that problem?

~]# cat /etc/issue CentOS release 6.8 (Final) ~]# java -version java version “1.7.0_111” OpenJDK Runtime Environment (rhel- u111-b01) OpenJDK 64-Bit Server VM (build 24.111-b01, mixed mode) ~]# echo $JAVA_HOME /usr/java/jre1.7.0_79 ~]# echo $BAHMNI_VERSION 0.83


I have the same problem as frodriguezm17. This is on Centos 6.8, Bahmni 0.83 all fresh install Any solutions?

@mkauzlar @frodriguezm17 Can you please try the steps mentioned under Upgrade Instructions of Release 0.83 (August 2016)


That worked, thank you sravanthi17