Demo server is Not Running/Unstable

Hello @cintiadr @dkayiwa,@ibacher we are having an up and down degrade of demo server ,it was running few hours ago and unfortunately went off, We tried to reset it via bamboo and also tried to run reference demo data unfortunately its still failing to run as expected , Not sure if it has its own separate dockerised Container than from that of ref-app-distro which could also help in rebuilding it to check its up and running but otherwise it still down thanks

Kindly try running again. It should be working now.

@sharif I must admit the demo server is not stable. After resetting it, it worked shortly and throw the error you shared.

Here’s log output from demo between a successful restart and failing again.

Perhaps @sharif, @dkayiwa, or others might be able to find a source for the instability there.

For example, around line 1648, I see an exception:

WARN - ModuleUtil.refreshApplicationContext(936) |2020-12-12 13:05:21,475| 
Unable to invoke started() method on the module's activator 
org.openmrs.api.APIException: Unable to install bundle AppointmentMetadata
Caused by: org.openmrs.api.ValidationException: 
failed to validate with reason: name: Name is duplicated
1 Like

Thanks @burke for your response, Ideally this concept Urology name is duplicate which recently caused reference demoData not to run as indicated here concept urology.

cc @dkayiwa, @ibacher As you indicated it here the problem is with the dbdump file that is used to pre-populate the qa-refapp database. Again in dbdump file as indicated here. We have concept name “Dermatology” using the same uuid=4d85dda4-c437-11e4-a470-82b0ea87e2d8 as that of Urology

Are you sure?

You are right they are different thanks, but i think the issue still resides in duplicate concept as suggested above