Can we keep Reference Application modules (omod files) in openmrs-webapp's /WEB-INF/view/module/ folder?


(Vamsi Krishna Rajulapati) #42

yes @dkayiwa.


(Daniel Kayiwa) #43

Are there any new changes in the file that you first sent?


(Vamsi Krishna Rajulapati) #44

Hi @dkayiwa, here are the most recent logs. openmrs-pod_logs.txt (59.3 KB)

openmrs_log.txt (53.0 KB)

Thanks


(Daniel Kayiwa) #45

What is the name of the file from which you are getting the contents for openmrs_log.txt? It is not the full log as i expected. It looks truncated.


(Vamsi Krishna Rajulapati) #46

the log file name is: openmrs.log only. As upload option is not allowing .log extensions I just copied it to text file.


(Daniel Kayiwa) #47

Can you try a non snapshot but officially released version? For instance the OpenMRS Reference Application version 2.8.1?


(Vamsi Krishna Rajulapati) #48

ok… sure… So I need to try with non snapshot version of Platform? Please confirm. I will try the same. Thanks


(Vamsi Krishna Rajulapati) #49

Hi @dkayiwa, As you suggested, I have tried with Platform version 2.1.4. Still facing the same issue. The app is working fine with Tomcat server. Its the issue with JBOSS EAP server.

ERROR - AbstractLoggingWriter.write(71) |2019-02-11 08:54:04,452| java.lang.IllegalStateException: JBWEB000243: Context /openmrs has already been initialized

openmrs_2.1.4_logs.txt (5.3 KB)

Could you please help to resolve the issue. Thanks


(Daniel Kayiwa) #50

I mean trying out the reference application version 2.8 https://openmrs.org/download/


(Vamsi Krishna Rajulapati) #51

I already tried reference application version 2.8.0 WAR but it didnt work for us as we were deploying it on JBOSS server.


(Daniel Kayiwa) #52

What is the meaning of it didn’t work for us?


(Vamsi Krishna Rajulapati) #53

the WAR file deployment didnt work for us because:

  1. When we deploy the WAR file on Openshift Origin - JBOSS EAP server, we faced the below issue:

Error: Invalid ‘log4jConfigLocation’ parameter: class path resource [log4j.xml]

  1. We cannot deploy the WAR, as there is no option to restart the OSO Pod. We were not able to keep the omod files and restart the application/Pod.

Thats why we are trying with openmrs-core module through source code.

Hope you understand. Thanks


(Vamsi Krishna Rajulapati) #54

Hi @dkayiwa, any suggestion from your side?

Thanks


(Daniel Kayiwa) #55

How about deploying an officially released war file, but afterwards edit the web.xml file in expanded openmrs folder?